WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Suffusion - Archives Page is Blank (12 posts)

  1. PerfectCr
    Member
    Posted 3 years ago #

    I recently switches themes to Suffusion. One problem, my Archives page is now blank. It used to be populated with a list of months and years. Where did it go? I tried copying the archive.php file to the suffusion directory and that didn't work. Can anyone help? Thanks!

  2. Sayontan Sinha
    Member
    Posted 3 years ago #

    You were using a custom template which your previous theme provided. Suffusion doesn't have an inbuilt "archives" template (which is different from an "archive" template). So unless you create a custom template for archives, it will not work.

  3. PerfectCr
    Member
    Posted 3 years ago #

    Yes I was using a theme (Journalist) that had a built in Archives Page. Is there a way to create one? If not, no big deal. :)

  4. Sayontan Sinha
    Member
    Posted 3 years ago #

    You could create a blank page, then use the Template Tag Shortcodes plugin, then insert a short code for [wp_get_archives]. This way you don't need a page template and your archives page will remain even if you switch themes.

  5. PerfectCr
    Member
    Posted 3 years ago #

    Awesome that worked!! Thank you! :) Now I just have to figure out why thumbnail images are intruding over blockquotes....

  6. nlpmesoon
    Member
    Posted 3 years ago #

    I have had a similar problem which commenced during Nov/2010, but I had not upgraded or changed anything that I am aware of during that time. For the months of Nov2010, Dec2010 and Jan2011, my blog only shows one or two posts, but there have been many more. Oct2010 displays fine in the Tabbed sidebar Archives.

    I did upgrade about 2 weeks ago to 3.x and the latest Suffusion theme to see if that would fix it - clean up some of the code or convert badly saved posts or something.

    I created another 3.x MU site and imported the exported posts in xml and the problem still persists on a totally new site, with no other content or random directory issues.

    I looked at some other posts - http://wordpress.org/support/topic/moved-blog-to-root-directory-archives-stopped-working?replies=5 to see if this was relevant, and still, as far as I can tell it is not.

    If I switch themes, (eg. default 2010) and the archives for those months are fully populated. If I switch back to suffusion, only some of the posts appear. I have tried the above method - "Template Tag Shortcodes" plugin, then insert a short code for [wp_get_archives] on a page and this looked promising, but when you click on these months, it is missing the exact same posts for each of the last 3 months?

    I am relying upon the Suffusion" Date-based Archive Page settings to display the archives in the tabbed sidebar.

    Is there anything else I could check?

  7. Sayontan Sinha
    Member
    Posted 3 years ago #

    No idea. Never encountered this.

    You haven't provided a URL, so my only guess is that you have Featured Posts at the top and the duplicate posts are getting excluded from the rest of the content.

  8. nlpmesoon
    Member
    Posted 3 years ago #

    Hi there and thanks for your response,

    Sorry the url is http://foryouremergence.com/2010/10/ for the month that works, and http://foryouremergence.com/2011/01/ is showing 0 of the 4 posts for Jan 2011. The first 4 posts in the Recents Tab are from Jan/2011. http://foryouremergence.com/ shows no posts, but using the Older link, it then starts displaying some of the posts (http://foryouremergence.com/page/2/), but only a few from Nov/2010 and continues to display all from Oct/2010...

    It is interesting what you are saying about duplicate posts - could this be being imposed by a plugin that provides canonical posts by only allowing urls to be generated in one format - like you say - Featured Posts or Recent Posts?

    The only reason why I came back to you as these symptoms change (displays all archives) if I use another theme.

  9. Sayontan Sinha
    Member
    Posted 3 years ago #

    Well, I do see that at least the first 2 posts on your Featured Content are from January (didn't verify the rest). Do this. Go to Blog Features → Featured Content → What to Show → Show Duplicate Posts, then show duplicate posts.

  10. nlpmesoon
    Member
    Posted 3 years ago #

    Perfect - that worked and I fixed my original blog too with the same adjustment. I would assume that 'Show Duplicate Posts' is probably a default setting in many themes and your 'Hide Duplicate Posts' is a good SEO option - the choice to 'Show Duplicate Posts' most likely breaks some of the SEO recommendations, but I will need to decide which way I will go with this - at least I have a choice and know where it is set.

    Nice to know there is no bug in the code of my posts or something. As I had used your Export/Import feature for the theme (great feature), I had carried the setting.

    Interesting that the symptoms of this 'problem' would have moved over time based upon the 'Number of Latest Posts' settings and as we wrote more posts, more archived posts would have appeared!

    Thanks again.

  11. Sayontan Sinha
    Member
    Posted 3 years ago #

    Well, more than SEO it is just that a lot of people prefer not having repetitive content on the same page.

    You really have many ways to skin the cat here. You might want to have your featured posts only on the front page, exclude duplicates there and don't show featured posts on other pages.

  12. nlpmesoon
    Member
    Posted 3 years ago #

    Thanks for these good points too... Will work on how I will do it... Thanks again and enjoy your coffee on us.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags