WordPress.org

Ready to get started?Download WordPress

Forums

sufficient permissions (7 posts)

  1. candv
    Member
    Posted 8 years ago #

    When I upgraded from 2.0 > 2.0.1 I got the issue of "You do not have sufficient permission" on the admin pages. The dashboard worked, but past that, nothing. The issues listed here (http://wordpress.org/support/topic/53261?replies=61) sum it up and it has no solutoin. When I saw 2.0.2 was released a few days I thought the issue would be resolved after the upgrade. No luck. Any ideas or similar issues? Thanks.

  2. Austin Matzko
    Member
    Posted 8 years ago #

    There are a number of proposed solutions there ( http://wordpress.org/support/topic/53261?replies=61 ). Did you try all of the them?

  3. spagornasm
    Member
    Posted 8 years ago #

    I've tried those solutions, and it is not fixing my problem. I still get just the dashboard, and when I try to do anything, including viewing my own profile, I get 'You do not have sufficient permissions to access this page."

  4. melilyn
    Member
    Posted 8 years ago #

    I also get this, and don't know how to fix it. alsdkfjslk!!

    This is what the admin panel is looking like:
    http://img236.imageshack.us/img236/1444/wpscreenshot8hg.jpg

    If you go directly to a page, such as themes.php or something, it tells you "you do not have sufficient permissions to access this page."

    All I did was upgrade exactly how it says.

  5. melilyn
    Member
    Posted 8 years ago #

    FIXED!

    I went into my cpanel, into the MYSQL database with PHPMyAdmin, into the usermetadata section [pardon my stupidness, I don't understand mysql in the least]. There were all of my users.

    For userid 1 [the admin account, obviously], it said this:

    a:1:{s:10:"subscriber";b:1;}

    and I changed it to this:

    a:1:{s:13:"administrator";b:1;}

    VIOLA! problem solved.

  6. traycee
    Member
    Posted 8 years ago #

    I have exactly the same problem with trying to upgrade WP locally using MAMP. I tried melilyn's suggestion but when I open up phpMyAdmin in MAMP I haven't a clue what I'm looking at. Any help much appreciated.

  7. allie12
    Member
    Posted 8 years ago #

    I've got the same problem but my usermetadata admistrator account is set correctly. HELP!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags