WordPress.org

Ready to get started?Download WordPress

Forums

Suexec (2 posts)

  1. shally87
    Member
    Posted 4 years ago #

    Hi, When I use Suexec my site is not responding very well.. Some times it load the site and sometimes it did not. There is also 1 time i get 500 internal error.

    By the way I realize when my site able to load and there is a few visitors, there is no multiple processes created compare to when I disable suexec and this does help me to fix the high ram usage in VPS.

    So anyone can help me fix this out? I was running wordpress and this is the list of my plugins

    Akismet
    All in One Adsense and YPN
    AskApache Crazy Cache
    AskApache Firefox Adsense
    Bad Behavior
    Delete Duplicate Posts
    Easy Tube (Disable)
    Excerpt Editor
    Google XML Sitemaps
    HeadMeta
    Hello Dolly
    Hyper Cache (Disable)
    P-Logger
    Save As Text and Html
    SEO Friendly Images
    SEO Smart Links
    SimplePie Core
    SimplePie Plugin for WordPress
    Simple Tags
    Social Bookmarks
    Twitter Tools
    Twitter Tools - Bit.ly URLs (Disable)
    Twitter Tools - Exclude Category (Disable)
    Twitter Tools - Hashtags (Disable)
    WP-o-Matic
    WP-UserOnline
    WP Auto Tagger
    WP Security Scan
    WP Super Cache
    WP Widget Cache (Disable)
    Yet Another Related Posts Plugin

    My VPS are running on lighttpd+Mysql+Php

    Regards
    Leo

  2. askapache
    Member
    Posted 4 years ago #

    Suexec shouldn't be causing these problems if i5s setup right.. I use suexec on all of my servers.

    Sounds to me like a permissions issue... make sure that the owner and group are correct on all the files/folders in your docroot. Also make sure the permissions of the files/folders are correct. Like the docroot folder is 751 or 755, the php files are 644, and check the php interpreter.

    If you can, set up logging for Apache and that will tell u quickly what u need to do.

    Finally, it may just be a simple matter of modifying your httpd.conf file settings like max servers.

    Or it could be that the system is setup to allow 5he nobody user that runs Apache to have much larger limits like how many processes and files are allowed open at one time- when using suexec the server will run as the user who owns the docroot, and that user might have much more restrictive limits. See limits.conf.

    There is a lot of info about this stuff at AskApache if you don't mind hard work.

    Good luck!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.