WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Suddenly not working - all 404 errors (4 posts)

  1. madwoman
    Member
    Posted 5 years ago #

    I was logged in to my newly set up blog and looking at a few things in the admin section, walked away for 20 minutes and when I got back and hit save on one of the setting pages I got a 404 error.

    Everything had been fine all morning, but now there s no admin, it just comes up with what should have been my main blog page but without the theme, and no admin anything.

    I checked the directories and everything is there best I can tell, how could this suddenly happen? What files should I be looking at or checking to fix this? (I can only assume something got hacked but I have no clue, and its a new site so I have practically no content and no readers yet that I know of)

    Thank you in advance

  2. madwoman
    Member
    Posted 5 years ago #

    I just can't find the problem and not sure where else to look.
    I closed my browser and rebooted, tried to get back to my WP admin area but I don;t get a login even though all the wp directories appear to be in tact. All I see is a 404 error with post and page remnants, no theme (yes, the theme directory and theme still do exist).

    As a last resort I suppose I could remove WP and start from scratch (ugh!) unless anyone has a better idea?

    Thank you :)

  3. Iva
    Member
    Posted 5 years ago #

    I'd suggest you to delete all the plugins first and see what happens. That's the first thing I would do in a situation like this.

  4. madwoman
    Member
    Posted 5 years ago #

    I didn't have any plugins enabled but thank you anyway SupersonicSquirrel :) I took the default 2 that were there and removed them just in case.

    I did manage to solve the problem though (yeah!)
    I disabled my .htaccess file and tried to get to the admin and of course got a standard 404 error page showing me the wp-login.php couldn't be found. Well, since I could see it there in the directory I realized that one of the changes I had made in the settings was the site url. My WP is in a subdirectory, and I was hoping one of the url options would actually allow me to have a link back to my main index page... apparently that isn't possible as I just found out.

    Anyway, I got into the mysql db and adjusted the setting back to include the subdirectory name that wp is in, and now it all works again. Phew!

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags