WordPress.org

Ready to get started?Download WordPress

Forums

Subscribe2
[resolved] Suddenly No Links to Posts In Emails (20 posts)

  1. CarrieM
    Member
    Posted 1 year ago #

    Hello! One of my subscribers just brought to my attention that the links to posts in my Subscribe 2 emails are gone, so they can't click through to my posts. I haven't changed anything in subscribe2, although I did update to the latest version of WordPress. Any help much appreciated!

    http://wordpress.org/extend/plugins/subscribe2/

  2. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @CarrieM,

    This is a known issue in Subscribe2 8.6. It'll be fixed in 8.7.

  3. CarrieM
    Member
    Posted 1 year ago #

    Thanks! How soon will 8.7 be coming out?

  4. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @CarrieM,

    Hopefully in the next 7 days if testing goes okay.

  5. jvoorhees
    Member
    Posted 1 year ago #

    This is a significant problem for me for a significant portion of our traffic comes through these e-mail digests. Any updates on a fix for this, or is there something I can do in the meantime?

  6. jvoorhees
    Member
    Posted 1 year ago #

    Actually, is there a way to go back to 8.5 until 8.7 comes out? I would simply install 8.5 over 8.6 but I'm afraid that the database tables have changed, and I don't want to lose my subscribers. Any thoughts?

  7. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @jvoorhees,

    The development code seems quite stable to me so you could manually install that or revert to 8.5. Do this via FTP and DO NOT uninstall the existing plugin in WordPress or you will lose all of your subscriber data and settings.

    Dev:
    http://downloads.wordpress.org/plugin/subscribe2.zip

    8.5
    http://downloads.wordpress.org/plugin/subscribe2.8.5.zip

  8. jvoorhees
    Member
    Posted 1 year ago #

    Cool. Many thanks.
    jv

  9. jvoorhees
    Member
    Posted 1 year ago #

    Hey, I tried installing both of the above and at least on the preview email the tablelinks function didn't work for either -- including the old 8.5 plugin. Any thoughts on what's going on?
    jv

  10. jvoorhees
    Member
    Posted 1 year ago #

    Never mind. I may have installed incorrectly. My fault.
    jv

  11. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @jv,

    Always like it when someone resolves their own issue :) Thanks for following up.

  12. goharris
    Member
    Posted 1 year ago #

    HI - is there a new eta for version 8.7? I'm somewhat loathe to go the ftp manual install route to fix the problem of the missing urls. My digest emails show blank space after "You may view the latest post at"

    Thanks.

  13. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @goharris,

    Next 48 hours I hope depending on how busy I am.

  14. 105creations
    Member
    Posted 1 year ago #

    Hello,

    I am experiencing the same problem as the OP above. However, the website I am working on has already updated to version 8.7 of the plugin, and the problem persists. Are there any other settings that may cause this problem?

  15. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @105creations,

    Have you checked your templates and made sure you are not using keywords that don't work in your email type (per-post or digest)?

  16. 105creations
    Member
    Posted 1 year ago #

    @mattyrob

    What are the correct settings/keywords to use if the email is sent out as a once-daily digest?

    Also, I'm noticing that the domain name of the email address sending out the emails doesn't match the domain name of the website in question. Is this another possible cause?

  17. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @105creations,

    All of the keywords are listed on the template page and with them is a brief description of what they do and also an indication if they are limited to one email type or another.

    In Digest emails you can't use {PERMALINK} or {TITLE} for example.

    I don't think the sender details will have an impact on the word substitution but it is worth fixing as it may well result in failed emails.

  18. lexthoonen
    Member
    Posted 1 year ago #

    So, how do I create a digest mail (as I did before, say in version 8.5 and before) with excerpts and a link underneath the excerpt of a post, followed by the next excerpt etc?

    Sorry for the question, it's probably something simple, but I don't see it now.

    Thanks!

  19. lexthoonen
    Member
    Posted 1 year ago #

    Ok, see, now they get a title and a link and an excerpt all in one with POST, that's cool.

  20. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @lexthoonen,

    It looks like you might have figured it out already but the {POST} keyword generates a title and link followed by an excerpt of the post.

    If you include {AUTHOR} anywhere in the template then the authors name is added on the same line as the title.

    If you add {TAGS} or {CATS} then these are listed after the link and before the excerpt of the post.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic