WordPress.org

Ready to get started?Download WordPress

Forums

Suddenly getting "It doesn't look like you've installed WP yet" error (15 posts)

  1. Arlo
    Member
    Posted 9 years ago #

    I woke this morning to find that my site is getting the "It doesn't look like you've installed WP yet. Try running install.php." error, seemingly randomly, when clicking on links:
    http://www.automatorworld.com

    I haven't touched the configuration at all, and this suddenly started happening. The site itself seems fine, when reloading links, but the error keeps popping up. Any ideas what would cause this?

    Edit: I discovered the reason: My host just upgraded to PHP 4.4.0. How can I get rid of this error?

  2. Mark (podz)
    Support Maven
    Posted 9 years ago #

    At a guess, check they have upgraded their Zend optimiser too.

  3. Arlo
    Member
    Posted 9 years ago #

    I don't know nothing bout no Zend, but this thread seems to indicate they didn't, and suggest PHP 5 as a workaround:
    http://forum.powweb.com/showthread.php?t=53647&highlight=zend

    So, what is my course of action here?

  4. Mark (podz)
    Support Maven
    Posted 9 years ago #

    3rd post there ?

  5. Mark (podz)
    Support Maven
    Posted 9 years ago #

    You pay them money - demand better service.

  6. Arlo
    Member
    Posted 9 years ago #

    Yeah, well..yeah. I went to Powweb based on its being recommended by WordPress, but thats another issue.

    In the meanwhile, how can I get rid of the error? I did the PHP5 change, it hasn't made a difference. Surely there is some check in WP that I can hack to bypass this error? Search turned up a few things, but they're a bit outdated, looking at the code.

  7. Arlo
    Member
    Posted 9 years ago #

    I hacked wp-settings.php and wp-blog-header.php by replacing $_SERVER['PHP_SELF' with $_SERVER['SCRIPT_NAME' which seems to be working. If there is a more elegant solution, I would love to see it, as hacking core files is of course not desirable.

  8. GregK
    Member
    Posted 9 years ago #

    Arlo -- your hack didn't work for me. I still get "It doesn't look like you've installed WP yet. Try running install.php."

  9. GregK
    Member
    Posted 9 years ago #

    Can I bypass this PHP upgrade problem by upgrading my installation of WordPress? I'm on 1.2 right now. If I upgrade to 1.5, will the problem go away?

  10. Arlo
    Member
    Posted 9 years ago #

    I have no idea if upgrading will work for you, I'm already on 1.5.. couldn' t hurt though, I suppose.

    What I don' t understand is, from reading some threads, Zend isn't even required by WordPress at all; in this thread, they even suggest turning it off to fix problems: http://wordpress.org/support/topic/18678

    And yet I am now running PHP5 with Zend turned on, and the error appears randomly. When I turn off Zend, I get the error continually (i.e the site won't load at all). Clearly the issue is more than just Zend. Podz, any ideas?

  11. fromedome
    Member
    Posted 9 years ago #

    Wow, Arlo, that's weird. I'm cruising your site fine for a second and then every 2-3 clicks the error occurs.

    I will make the brazen assumption that WP and their user base have tested the app under that (and most) versions of PHP.

    Hoping a fix comes to you soon. Nice site btw.

  12. Arlo
    Member
    Posted 9 years ago #

    I dunno, I'm at a loss here. Everyone is passing the blame to everyone else, and my site is still catatonic. It seems to me there should be a simple fix to this, some way some how.

    Podz, you seem to be the living knowledgebase around here, is there anything I can do on the WP side to stop this error?

  13. Arlo
    Member
    Posted 9 years ago #

    Powweb is telling me they are updating Zend soon. But I still have doubts that's the only problem here. As pointed out earlier, I had Zend completely turned off, and the problem persisted.

    Does ANYONE have any insight into this?

  14. Arlo
    Member
    Posted 9 years ago #

    Update:
    Thanks to a PHP whiz friend if mine, I changed the function update_user_cache() in functions.php to always return "true" and this has fixed the problem..in a not very elegant way.

    Perhaps someone who knows WordPress can reverse engineer this situation to point out what the root problem may be?

  15. lucazappa
    Member
    Posted 9 years ago #

    I have update to 10 the field user_level in the users table of wordpress and I solved the problem

Topic Closed

This topic has been closed to new replies.

About this Topic