WordPress.org

Ready to get started?Download WordPress

Forums

Google Doc Embedder
[resolved] Suddenly getting error: GDE Error: Unable to load profile settings (40 posts)

  1. servent1
    Member
    Posted 1 year ago #

    Updated to WP 3.5 and now I"m getting the above error message. Have 2.5 installed. Is there a compatibility issue here?

    http://wordpress.org/extend/plugins/google-document-embedder/

  2. servent1
    Member
    Posted 1 year ago #

    Had to go back to previous version and as mentioned in a recent post and works fine.

  3. k3davis
    Member
    Plugin Author

    Posted 1 year ago #

    Going back to the previous version is not the best fix for this issue. A few people have reported this on upgrade installs. Have you not been able to solve it with a clean install?

    It seems most who have this issue (I haven't been able to reproduce it) see it fixed just by deactivating and reactivating, but a clean install isn't a bad idea.

  4. servent1
    Member
    Posted 1 year ago #

    Thanks! Cleaned install worked. Was going to try that but not sure why I didn't Daaaaaa. :)

  5. k3davis
    Member
    Plugin Author

    Posted 1 year ago #

    Sorry for the trouble. There seems to be some problem with the upgrade routine that converts 2.4.x settings to the new 2.5 format, but I don't see the problem on my end so it's hard to track down. I'm hoping someone who has experienced this problem will be able to send me an error log with the details, or give me access to a test site where it's occurring to test it out.

    I know not everyone has the time or access to invest in that, though. I'm glad the clean install worked for you. :)

    Note there are a few issues some have seen with WP 3.5 (which this thread says you're running). I'm currently investigating these. If you run into any more snags, please let me know.

  6. lbonesini
    Member
    Posted 1 year ago #

    Disabling and re-enabling the plugin solved the issue on my installations.

  7. onesoftindiana
    Member
    Posted 1 year ago #

    Earlier I was having the same problem, then I had a clean install. Now I encounter the following errors.

    1. `Warning: array_keys() [function.array-keys]: The first argument should be an array in /home/gomilita/public_html/exam/wp-content/plugins/google-document-embedder/functions.php on line 161

    Warning: implode() [function.implode]: Invalid arguments passed in /home/gomilita/public_html/exam/wp-content/plugins/google-document-embedder/functions.php on line 161`

    2. GDE Error: Error retrieving file - if necessary turn off error checking (301:Moved Permanently)

    3. GDE Error: Unsupported File Type (pdf)

    While one of the pdf is running perfectly well.

    Check out - http://exam.gomilitary.in/downloads
    to understand the problem more clearly.
    Thanks.

  8. k3davis
    Member
    Plugin Author

    Posted 1 year ago #

    I can't account for all those errors individually, but there is a fix for 1 & 3 specifically in GDE 2.5.3. If you find #2 isn't also relieved by the update, please let me know.

  9. galgoog
    Member
    Posted 1 year ago #

    .uninstalled the plugin
    .reinstalled it
    >now it works fine (using WordPress 3.4.2)

  10. k3davis
    Member
    Plugin Author

    Posted 1 year ago #

    I'm sorry about that. 2.5.x has had some growing pains in spite of having 600 beta testers... I believe it's stable now. Thanks everyone for your patience.

  11. onesoftindiana
    Member
    Posted 1 year ago #

    Thanks for the updates. Problem 1 and 3 are solved now.
    But No.2 still persists.

    What should I do to get rid of it.

  12. k3davis
    Member
    Plugin Author

    Posted 1 year ago #

    What is different about the shortcode on those items, where some are working and some aren't? Are the broken ones linked from a different site, etc.?

    You can try going to the "Advanced" tab and unchecking "Check for errors before loading viewer," though ideally I could have the shortcode you're using and try to identify the underlying problem with those documents.

  13. onesoftindiana
    Member
    Posted 1 year ago #

    Ohh..yes..those files are uploaded in the main domain while the ones that are displayed are on the sub-domain itself.

    I'm using the same shortcodes for all the files ..
    i.e. [gview file="url"]

  14. k3davis
    Member
    Plugin Author

    Posted 1 year ago #

    It looks like the issue may be that those 2 files are in folders with spaces in the name. GDE corrects filenames with spaces (not a good idea on a Linux server), but doesn't do anything with directory names. If turning off error checking doesn't solve the issue, I'd suggest one of these solutions:

    * Rename the "Go Military Data" folder to "Go-Military-Data" (if this won't break a lot of links on your site).
    * Change the URL of your document in the shortcode to use the directory name Go%20Military%20Data (spaces encoded) and see if that works any better.
    * Move the documents in question to your wp-contents folder (or another without spaces) like the others.

  15. onesoftindiana
    Member
    Posted 1 year ago #

    I already have the shortcode as http://www.gomilitary.in/Go%20Military%20Data/Pdfs/ssb-tips-collection-gomilitary.in.pdf

    and http://www.gomilitary.in/Go%20Military%20Data/Pdfs/My%20Appointment%20with%20a%20Psychologist.pdf

    ----------------------------------------------
    But earlier to the wordpress update, they were working prefectly. Do you know why they aren't after the update.

  16. k3davis
    Member
    Plugin Author

    Posted 1 year ago #

    I'm looking into it, but I've confirmed turning off the setting I mentioned above solves the problem you're having in the meantime.

  17. onesoftindiana
    Member
    Posted 1 year ago #

    You can try going to the "Advanced" tab and unchecking "Check for errors before loading viewer," though ideally I could have the shortcode you're using and try to identify the underlying problem with those documents.

    yes. that works. Thanks a lot. Your help is really appreciated.

  18. k3davis
    Member
    Plugin Author

    Posted 1 year ago #

    OK, that took some doing, but I found the problem. The answer is a bit technical so feel free to ignore if you're not interested. ;)

    In 2.5.x I changed the method of URL validation to use a HEAD request instead of a GET. This speeds up the process a lot, since it doesn't have to fetch the whole file in order to validate it, but only the header. The problem is, when URLs contain spaces, the browser must redirect to the encoded version, since spaces are really not valid in URLs. In WP, HEAD requests (properly) don't follow redirects, so this method fails.

    This issue will be patched in GDE 2.5.4. If the URL contains spaces, it will perform a full "GET" instead of just a "HEAD" request. The GET request will follow redirects and return the real status of the file. This is still a bit slower and it's better not to use spaces. ;)

    The most obvious benefit of this fix over just turning off error checking is the file size will be accurate instead of "Unknown."

  19. dcraggs
    Member
    Posted 1 year ago #

    I'm getting problems with this as well. Uninstalled and reinstalled and now getting:

    GDE Error: Error retrieving file - if necessary turn off error checking (200:OK)

    HELP!!!!

  20. k3davis
    Member
    Plugin Author

    Posted 1 year ago #

    I don't know what document you're trying to embed or anything, so I can't really guess. Have you tried turning off error checking, as the error message suggests?

    GDE Settings > "Advanced" tab > uncheck "Check for errors before loading viewer"

  21. dcraggs
    Member
    Posted 1 year ago #

    I have done that, all I get now is a blank area where the doc (PDF) should be displayed.

  22. dcraggs
    Member
    Posted 1 year ago #

    The download link is displayed.

    here is the website:

    http://www.stclareschester.org.uk/?p=925

  23. k3davis
    Member
    Plugin Author

    Posted 1 year ago #

    The document is displaying normally there. You are probably a victim of your own browser cache.

    http://www.davistribe.org/gde/notes/#browser

    Please completely clear your browser cache or try from another computer/device to see that it is indeed working.

    Merry Christmas.

  24. dcraggs
    Member
    Posted 1 year ago #

    Wierd, can't see it using Safari on my iPad, but can using Chrome. On my desktop can't see it with Chrome, but CAN with Safari.

  25. godzookee
    Member
    Posted 1 year ago #

    I had the same issue. Was sorted just by deactivating the plugin and reactivating it.

    Keep up the great work.

  26. ThorsDad
    Member
    Posted 1 year ago #

    I had the same problem. I had to deactivate/reactivate the plugin to get to the settings. Then I did the: GDE Settings > "Advanced" tab > uncheck "Check for errors before loading viewer"

    Seems to work now.

  27. mrjarbenne
    Member
    Posted 1 year ago #

    I was seeing the same error. This is a fresh install of 2.5.4 (not an update). I tried deactivating and reactivating and the same error existed. I then turned off the error check, and the viewer loads, but the Public Google Document does not appear, and instead the viewer is filled with code:

    <!DOCTYPE html><html><head><meta name="google" content="notranslate"><....

    Here's the post: http://sandbox.commons.hwdsb.on.ca/2013/01/27/class-act/

  28. k3davis
    Member
    Plugin Author

    Posted 1 year ago #

    Hello,

    First off, I have no idea what turning off error checking has to do with the discussion, other than somebody suggested it. Error checking and profiles are not related.

    I have a fix for the profile issue pending the next update. In the meantime deactivating and activating the plugin again is confirmed to fix it in every instance I've heard of.

    Finally, mrjarbenne, the plugin isn't for Google hosted documents, but for privately hosted documents. Please read the FAQ ("Does it work with files saved in Google Docs/Drive?").

    This thread is getting convoluted - please start a new thread if you're not having the same issue as above. The conflicting information here makes my free support job more difficult. Thanks all for your consideration!

    Kevin

  29. mrjarbenne
    Member
    Posted 1 year ago #

    Profuse apologies. I misunderstood the use of the plugin, then saw the error and assumed I was running into the same issue. Clearly you do an excellent job supporting this plugin. Have a good day.

  30. k3davis
    Member
    Plugin Author

    Posted 1 year ago #

    Sorry if I came across too strongly there; apologies aren't necessary. Just trying to keep my plugin support life sane. ;)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.