WordPress.org

Ready to get started?Download WordPress

Forums

Sudden 'Error Establishing a Database Connection' (10 posts)

  1. Coolnat2004
    Member
    Posted 8 years ago #

    Alright.. well I successfully had WP running at krinj.net/2004design/blog. I moved the database and files to blog.nathanbolender.com and it worked for a little over a month. Then, a couple weeks ago, it just started displaying 'Error Establishing a Database Connection'.

    I checked the wp-config.php file, and even updated the MySQL password on the server. All of the information is correct, but the error still persists. No changed have been made to the server, and it's running MySQL 3.23.58 and it is some Unix variation (FreeBSD I believe).

    Again, the main point is that it was working, and now it is now.

    Oh, also, I have another site on the same server running phpBB, and it works fine - so the MySQL service is operating correctly. Can anyone suggest what to do? Thank you!

  2. Mark (podz)
    Support Maven
    Posted 8 years ago #

    What did your host say about this ?
    What changes have they made ?

  3. James
    Happiness Engineer
    Posted 8 years ago #

    Your host may have upgraded to MySQL v4.1.7. See: http://codex.wordpress.org/Answers-Installation#MySQL_4.1.7

  4. Coolnat2004
    Member
    Posted 8 years ago #

    They have not made any changes. It is still running MySQL 3.23.58.

  5. Coolnat2004
    Member
    Posted 8 years ago #

    I just tried uploading fresh WP files, it did not work. I also tried replacing localhost for 127.0.0.1, that did not work, neither did entering the domain. I changed the MySQL password and it still does not work..

    Does anyone have any idea how I can get this back up and running?

    Oh, and apparently they are running Red Hat Linux.

  6. Coolnat2004
    Member
    Posted 8 years ago #

    Apparently this is a problem with the host.. I used a different account on the same server and now it works..

  7. jameslynn
    Member
    Posted 8 years ago #

    I had the same problem. Everything was working fine and today I got the [strong]'Error establishing a database connection[/strong]'error message.
    What do you mean by using a different account on the same server? Different login to the database or different user on the server?

    :(

  8. jameslynn
    Member
    Posted 8 years ago #

    Well, I created a new user for the database with an eight character password.

    That solved the problem... for now
    ;^)

  9. James
    Happiness Engineer
    Posted 8 years ago #

    Both of you might want to try repairing your tables. See: http://www.tamba2.org.uk/wordpress/repair/

  10. fczuardi
    Member
    Posted 8 years ago #

    Thanks to the above comment, it worked after the repair table!

Topic Closed

This topic has been closed to new replies.

About this Topic