WordPress.org

Ready to get started?Download WordPress

Forums

sudden disappear of visual editor (80 posts)

  1. xinfo
    Member
    Posted 7 years ago #

    Hi

    so long ever thing work fine

    today i found that sudden disappear of visual editor when writing.

    ordinary write also found missing .

    Double checked

    visual editor enabled
    java script enable

    i found same bug here also
    http://demo.opensourcecms.com/wordpress

    login:admin
    pass:demo

  2. mortenskyt
    Member
    Posted 7 years ago #

    Hey, I have the same issue. Resolved it by creating a non-admin user, as they seem to have access to use the editor. I observed that if you ever make a user admin, it'll no longer have access to the "graphical" editor. I have no idea why this strange limit has been imposed, but it sure is annoying...

    Regards,
    Morten Skyt

  3. xinfo
    Member
    Posted 7 years ago #

    mortenskyt

    i create new user as editor and enabled the visual editor for the user now in my admin side i find that ordinary editar appear still visual editor didn't appear

    btw :so long it's [visual editor] working with out any problem why suddenly ?

  4. xinfo
    Member
    Posted 7 years ago #

    fresh installed also i have same above problem , well i installed in my pc it's work well so it's not browser problem also .

  5. xinfo
    Member
    Posted 7 years ago #

    i found recently from my havascript consol firefox

    few error

    i belive due to this i can't get the editor

    Warning: test for equality (==) mistyped as assignment (=)?
    Source File: http://www.domain.com/wp-includes/js/prototype.js?ver=1.5.0
    Line: 125, Column: 39
    Source Code:
          if (match = source.match(pattern)) {
    Warning: anonymous function does not always return a value
    Source File: http://www.domain.com/wp-includes/js/prototype.js?ver=1.5.0
    Line: 731, Column: 2
    Source Code:
      },

    any solution

  6. paburmester
    Member
    Posted 7 years ago #

    I had same problem :(

  7. RavanH
    Member
    Posted 7 years ago #

    Same here!

    Cannot -for the life of me- figure out what is causing this.

    Definately not a plugin problem (disabled them all) nor a browser related issue (both IE and FF) nor a admin user thing (admin, editors and subscribers)...

    Only thing I can see is that the blog that has this problem is in a subdirectory and not the web-root:

    WordPress 2.1.1 (upgraded straight from 2.0.5)
    PHP 5.0.4
    MySQL 4.1.20
    WordPress Address (URL): http://mydomain.com/wordpress
    Blog address (URL): http://mydomain.com

    In contrast: another blog running on the same server, only another domain, doesn't have the ritch editor problem. The only differences (beside the domain name) that I can think of are:
    1. WP is installed directly in the web-root and not a subdir...
    2. Upgrade history was different: 2.0.5 > 2.0.7 > 2.1 > 2.1.1 (not straight from 2.0.5)

    Anybody any ideas?

  8. tryintolearn
    Member
    Posted 7 years ago #

    I'm not sure if the problem I'm having is related to what the rest of you are describing or not. When I click on either "Write" or "Write A New Post" I just get a blank page. Not an error page, just a totally white page. I was posting fine earlier today. Is anyone else having this problem? I tried creating a new user name like someone had suggested but it didn't help.

  9. RavanH
    Member
    Posted 7 years ago #

    Sorry tryintolearn, that is another issue... in the case discussed (or rather: reported, without any solution) here it is a Write page that loads but does not show the rich text editor (TinyMCE) like it should.

    To see it 'in action' go to http://demo.opensourcecms.com/wordpress , click 'login' and use the following info -
    login:admin
    pass:demo

    Then go to 'Write' and see what happens. In our case, the page loads but there is no text editing possible, just a textarea field without the rich editing options.

    If you only see a blank page there also, it might be your browser that is causing a problem?

  10. tieguy
    Member
    Posted 7 years ago #

    I'm seeing this post-upgrade too. I only have one user (the admin user) on my blog. Oddly, I didn't see the problem until after I changed something in the admin user prefs- I did the upgrade from 2.0->2.1, used it for a week with no problems, and then added a website URL to the contact info for my admin user. Immediately after that, the visual editor disappeared (and the automatic preview-on-save too.)

    Hope that little detail helps someone clarify/fix the problem.

    [BTW, is there a bugtracker for wp? This definitely seems like a bug, and not just a support issue.]

  11. tieguy
    Member
    Posted 7 years ago #

    Ah-ha. If you just go into users->your profile, and click 'use the visual editor when writing', you get the visual editor back. Now, it is still a bug that this somehow gets unchecked when you edit the page, but... obviously easy to resolve once you've poked around a bit :)

  12. YellowSwordfish
    Member
    Posted 7 years ago #

    Except after what I think is the 2.11 upgrade I have lost the RTE AND the option under Your profile. The checkbox has vanished...

  13. xinfo
    Member
    Posted 7 years ago #

    YellowSwordfish

    your wp-includes is Corrupted. delete your wp-includes folder and upload freshly

  14. RavanH
    Member
    Posted 7 years ago #

    Tieguy, indeed there is a checkbox for 'Use the visual editor when writing' on the Users>Your Profile page... I am supposing that this is checked? If not, you should see only some quick-edit buttons above the textarea on your Write page. If checked, there should be a more extensive bar with fancy editor icons... In my case NOT :( . I have no problems with the checkbox 'unchecking' or anything... just no RTE.

  15. RavanH
    Member
    Posted 7 years ago #

    Decided to test some more. Three test-sets:

    1. I downgraded (if you can call it that) version 2.1.1 to version 2.0.7 - disbaled all plugins and overwriting all files (except wp-config.php)... After running the upgrade process, still no RTE.

    2. Did a clean install of WP 2.0.7 complete with new database and fresh (empty) content. The RTE works like I am used to! Now upgraded that clean install of 2.0.7 to 2.1.1... RTE gone again :(

    3. Again a clean install of 2.0.7 (like before with the RTE working fine) and uploaded 2.0.9. Run the upgrade.php process manually because it didn't start up automatically. RTE was still purring like a kitten :)... Then upgraded to 2.1 (upgrade process ran automatically), logged in and went to the Write page. No RTE but the conventional editor so went to Users>Your Profile and checked 'Use the visual editor when writing' because that setting apparantly was changed during upgrade (stange). Then went to Write page: TRE not working!!!

    4. Did a clean install of WP 2.1 with clean database: still no RTE, ofcourse...

    The strange thing is that I have another WP 2.1.1 installation running on the same server, with TRE! I'm completely at a loss here. Will revert to 2.0.9 untill this is resolved.

  16. natursyn
    Member
    Posted 7 years ago #

    I also have the problem that I cannot get the rich text editor to work (it does not show) neither on http://demo.opensourcecms.com/wordpress or on my own site. I've tried IE7, FF2 and to turn off my own anti-virus.

  17. giftedtypist
    Member
    Posted 7 years ago #

    RavanH, is this visual editor check box on WP 2.1.2. I can't see it anywhere and I've lost my wysiwyg editor and could use it back soon

  18. www.onlinecasinoselite.com
    Member
    Posted 7 years ago #

    RavanH, is this visual editor check box on WP 2.1.2. I can't see it anywhere and I've lost my wysiwyg editor and could use it back soon

    that checkbox should be in Users > Your profile

  19. www.onlinecasinoselite.com
    Member
    Posted 7 years ago #

    Will revert to 2.0.9 untill this is resolved.

    sadly, me too...

    I can't get Zenphoto+Zenpress to work, tried everything but nothing, nada, zero :(

  20. giftedtypist
    Member
    Posted 7 years ago #

    Where?
    There is no such check box in my user > your profile. I've looked a number of times. I've just upgraded to 2.1.2. Perhaps it is somewhere else? I coudl really do with a visual functionality - I wouldn't have gone to WP if I'd know I had to do it in code

  21. Chris_K
    Member
    Posted 7 years ago #

    Click Users.
    In the sub menu below it click "Your Profile.

    The *very* top option. Titled, "Use the visual editor when writing".

    Check it.

  22. giftedtypist
    Member
    Posted 7 years ago #

    I swear up and down there is no such box.

    Under Users> "Your profile
    AT the very top the header says:
    "Your profile and personal options"
    "personal options"
    update profile button (on right)
    then two columns with info boxes
    name Contact info

    About yourself update your password

    And that is it. Not visual editor box. Is it somewhere else in 2.1.2?

  23. Chris_K
    Member
    Posted 7 years ago #

    Nope. Are you *positive* you're at 2.1x?
    In 2.0.x it was the very BOTTOM of that same "Your Profile" page.

    Oh hey, what OS/Browser are you using?

  24. giftedtypist
    Member
    Posted 7 years ago #

    IE 7
    Just updated to WP 2.1.2 yesterday due to dangerous 2.1.1 messages.
    Big problems with posting, uploading pix and managing posts, perhaps this explains absense of visual editor and visual editor button.

  25. w4rn1ng
    Member
    Posted 7 years ago #

    Someone mentioned futher up this thread if the checkbox under your profile is gone you might want to re-upload wp-includes.

    I am just chiming in to say that I just installed wordpress on my webhost last week, and can use the visual editor fine. However another user registered, and I made him an author, however with or without the box checked under his profile his visual editor does not appear in IE7 or Firefox 2.0.0.2.

    He runs his own wordpress blog (altho slightly outdated) and his visual editor works there so it is not a browser issue.

  26. giftedtypist
    Member
    Posted 7 years ago #

    I re-uploaded wp-include but there was no change
    I set myself up as another user but still no change. I can't get the visual editor and there is no button to activate.
    I'm on IE 7. It worked in 2.1.1

    Can anyone help?

  27. www.onlinecasinoselite.com
    Member
    Posted 7 years ago #

    So I finally decided to downgrade to 2.0.9, and now it works as usual (great).

    I created a new database, to avoid messing with the old one, and I think I'll wait until these issues are solved before upgrading again :\

    giftedtypist, try using another browser, like Firefox.
    I also did what you have done, reuploaded files and folders, etc., but nothing seemed to work...

  28. giftedtypist
    Member
    Posted 7 years ago #

    I've download FF and I'm still without a visual editor, still no visual editor button box

    Is there something in the wp-admin or wp-includes file I should change?

    Should I down grade 2.1.2 to 2.0.9?

  29. www.onlinecasinoselite.com
    Member
    Posted 7 years ago #

    well man, it's your decision to downgrade or not.

    Have you tried disabling ALL the plugins? Try that and check if the visual editor returns.
    If it does, re-activate the plugins one by one, checking if the visual editor doesn't get broken by one the plugins.

  30. giftedtypist
    Member
    Posted 7 years ago #

    Thanks. I had no plugins activated. I'm new to this and I'm still trying to get the blog up and running. Then I would think about plugins.

    Here's something interesting though, the editor on this screen here is also code, not visual. Is that the case for everyone?

Topic Closed

This topic has been closed to new replies.

About this Topic