WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Sudden 500 Server Error (8 posts)

  1. leetlefish
    Member
    Posted 1 year ago #

    Hey I have 6 websites on my Hostmonster server. About a week ago, 3 of them started returning 500 server errors. I hadn't modified any of them. No new themes, plugins, not even posts. I only found out that they had server errors cause a friend tried to visit my site and told me. I was only able to check how long they had been down by looking at my Google Analytics.

    All 3 of the affected sites are WordPress powered. In addition, there are 2 more WordPress sites that were unaffected, and one Non-wordpress site.

    I have tried the stock responses that Hostmonster suggested to no avail. I tried renaming my .htaccess document, with no effect (one of the sites doesn't even have one). I tried renaming my themes folder and my plugins folder to see if it resolved the problem...nothing. One of the sites started returning a WSOD instead of a 500 server error-but that was it. Didn't really make sense that it would be a plugin or theme anyway, since I didn't change anything...

    Kind of at a loss about what to do here. I have tried checking for a problem in the error logs by refreshing the website and then refreshing the error logs, but I never see my IP...Any thoughts or suggestions?

    The sites in question are:
    http://www.howtomakesushiathome.com
    http://www.beijingmemos.com (currently returning a WSOD)
    http://www.pretentiouswhat.com

    Thanks!

  2. leetlefish
    Member
    Posted 1 year ago #

    oh, also, and I don't know if this will provide some kind of clue, but it's still loading my favicon for http://www.howtomakesushiathome.com. How would it be able to load the favicon but return a server error for the rest?

  3. BH_WP_Guru
    Member
    Posted 1 year ago #

    I see WSOD for all 3 (some browsers will show a 500 error when its a blank white screen, but Firefox will show the real white screen).

    First thing you should try is to make sure that the setting of display_errors = On instead of Off in your php.ini file. I know that Bluehost sets all customers to Off by default. Normally the php.ini will be in your public_html folder, but if you don't have one yet, you can have cPanel make you one by going to the icon "PHP Config". Make sure you are editing the line that says display_errors that does not start with a ; (semicolon) to the left, there might be more than one.

  4. BH_WP_Guru
    Member
    Posted 1 year ago #

    Sorry, should have said Hostmonster. Hostmonster/Bluehost same company.

  5. bhpress
    Member
    Posted 1 year ago #

    You can also edit your wp-config.php if you don't want to mess with the php.ini. Simply go in to edit it and find the line that contains

    define(‘WP_DEBUG’, false);

    Change that to

    define(‘WP_DEBUG’, true);

    This will make your errors show up on screen instead of the WSOD. You will want to make sure you change that back after you fix it. I know Hostmonster has a good article on fixing it once you know the cause

    https://my.hostmonster.com/cgi/help/571

  6. leetlefish
    Member
    Posted 1 year ago #

    Thanks for the information and links guys. I got it figured it out!

  7. leetlefish
    Member
    Posted 1 year ago #

    To add, the hostmonster info page on the subject was far more useful than the troubleshooting guide that the tech sent me, and in much more detail.

    Two of the sites had plugin issues, one site had a theme issue. I'm not sure why I wasn't able to discover that the FIRST time I tried renaming the theme and plugin folders, but it's working fine now.

  8. bhpress
    Member
    Posted 1 year ago #

    I"m glad that you got it working!

Topic Closed

This topic has been closed to new replies.

About this Topic