WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Successfully Deployed Site Locally - Permalinks Don't Work (3 posts)

  1. CallUp
    Member
    Posted 4 years ago #

    Over a week ago, on my local WAMP setup, I changed the website and blog urls in the admin general settings, and then moved my files to what I believed would be the new server path, and created a big mess.

    Anyways, after much frustration, I ended up just moving my new Theme online (live) to where my site was, and got it all working. Today, I just uninstalled WAMP and deleted my wordpress setup, locally. Then reinstalled WAMP, FTP'd by Theme and MySQL from my CPanel down, and got it all up and running here locally.

    So my front page looks perfect (everything in place, including content (database), but my links (permalinks) are all dead links. And, accordingly my Login page doesn't work.

    When I hover over them they are correct (i.e. http://localhost/page). I've been looking through my phpMyAdmin at the wp-options tables to see if there's anything that needs to be changed regarding permalinks, but I can't find anything.

    Can anyone help?

    Thanks.

  2. Samuel B
    moderator
    Posted 4 years ago #

    don't bump against forum rules

    If you want to use permalinks, you will need to make a change inside another file:
    file httpd.conf. Open that in a text editor. Use the search facility in the editor to find "rewrite". The line you need looks like this:

    #LoadModule rewrite_module modules/mod_rewrite.so

    You need to take away the hash sign so it looks like this

    LoadModule rewrite_module modules/mod_rewrite.so

    Now just save the file.

    ref
    http://www.tamba2.org.uk/wordpress/xampp/

  3. CallUp
    Member
    Posted 4 years ago #

    samboll,
    You ROCK! Once again, you have resolved my issue in moments.

    Thanks again for all your help.

Topic Closed

This topic has been closed to new replies.

About this Topic