WordPress.org

Ready to get started?Download WordPress

Forums

SUBSITUTE OF ROLE SCOPPER (10 posts)

  1. wealthze
    Member
    Posted 3 years ago #

    Word press 3.1 is very problematic so please tell how can I find compatible plug ins with this theme. Specially please suggest a substitute of role scoper because my web needs that plugin but it's not compatible with 3.1.

  2. kevinB
    Member
    Posted 3 years ago #

    Role Scoper doesn't require WordPress 3.1. The current version runs on WP 3.0 and higher. Older RS versions are available for WP 2.9.

  3. wealthze
    Member
    Posted 3 years ago #

    yes that's what I am saying that role scoper is not compatible with 3.1. so suggest me what's the alternative now.

  4. esmi
    Forum Moderator
    Posted 3 years ago #

    The current version runs on WP 3.0 and higher.

  5. kevinB
    Member
    Posted 3 years ago #

    wealthze, The Role Scoper development version (1.3.28-dev) fixes some problems in accessing Role Scoper's own Multisite options. If you are aware of any other problems with 3.1 compatibility, please report them.

  6. kevinB
    Member
    Posted 3 years ago #

    Further investigation showed this to be a configuration issue. The Post Reader role was restricted by default for all categories (Restrictions > Categories). A post with such a restriction on all its categories is readable only to users who have a role assigned directly to a category or to the post itself. It is possible to selectively negate this effect by unrestricting the Post Reader role for desired categories. However, since none of the categories were unrestricted all content was hidden from anonymous readers.

  7. kenbird
    Member
    Posted 3 years ago #

    I have a conflict between the Role Scoper plugin and the Alo Easymail Newsletter. If I want to use the ALO Easy Mail Newsletter, I have to deactivate the Role Scoper plugin.

  8. kevinB
    Member
    Posted 3 years ago #

    I'll look into the ALO plugin conflict after returning from vacation next week.

    Next time, please open a new topic.

  9. kevinB
    Member
    Posted 3 years ago #

    What exactly is going wrong with the Newsletters with Role Scoper active? Can you resolve it by deactivating RS filtering of the Newsletter post type (Roles > Options > Realm > Post Type Usage)?

  10. kenbird
    Member
    Posted 3 years ago #

    Hello kevinB

    Thanks for the reply. I decided to resolve the conflict by preferring the use of ALO Easymail Newsletter and deleting the Role Scoper plugin because of the incompatibility. I am using User Role Editor instead of Role Scoper and it is compatible with ALO Easymail Newsletter. Many thanks for your assistance to me.

Topic Closed

This topic has been closed to new replies.

About this Topic