WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Subsites newly created keep redirect to wp-login.php from super-admin dashboard (3 posts)

  1. gametorus
    Member
    Posted 1 year ago #

    Dear WordPress expert;
    I'm new to wordpress and also to this forum so apologies in advance if i didn't bring enough information.
    I have searched but couldn't find a direction for the resolution.

    Issue:
    Adding site (already 2 subsites created without issue): OK under super-admin. First time I open the dashboard it ask me to log wordpress/sitename/wp-admin.php. Dashboard is shown OK. Whatever I select i keep redirected to the login page as the example below.
    /wordpress/training/wp-login.php?redirect_to=http%3A%2F%2F<IP_Address>%2Fwordpress%2Ftraining%2Fwp-admin%2Foptions-general.php&reauth=1

    Environment:
    OS: OpenSuse 12.1
    webserver: Apache/2.2.21
    Database: libmysql - mysqlnd 5.0.8-dev
    site address: http://IP_Address (developpment)

    Only one user : super-admin
    Theme Twenty Eleven : Network Enabled
    Fresh install of WordPress multisite : OK
    multisites subdirectories
    Already 2 sub-sites created without issues
    No DNS Mapping plugin installed

    wp-config.php

    /* Multisite */
    define('WP_ALLOW_MULTISITE', true);
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', false);
    $base = '/wordpress/';
    define('DOMAIN_CURRENT_SITE', 'IP_Address');
    define('PATH_CURRENT_SITE', '/wordpress/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);

    .htaccess

    <IfModule mod_rewrite.c>
    
    Options +FollowSymLinks
    
    RewriteEngine On
    RewriteBase /wordpress/
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    
    </IfModule>
    
    php_value upload_max_filesize 256M
    php_value post_max_size 256M
    php_value max_execution_time 300
    php_value max_input_time 300

    Steps Already done:
    Enter the exact same settings from site which work to site which not from Network Dashboard.

    I don't know where to search to solve the issue database? wp-config.php? .htaccess? plugins?...

    Hopefully, it's an easy resolution.

    Many thanks in advance for your help.

  2. What plugins are you using?

  3. gametorus
    Member
    Posted 1 year ago #

    Hello Mika;

    You direct me in the right direction. I was feeling the same. I have removed auto-logout plugin and works right away.

    Thanks a mill.

Topic Closed

This topic has been closed to new replies.

About this Topic