WordPress.org

Ready to get started?Download WordPress

Forums

Subsites don't have the correct admin links (5 posts)

  1. John Bunka
    Member
    Posted 2 years ago #

    When a sub-user clicks "New Post" on the Admin toolbar, the link shows/reads as http://mainsite.com/wp-admin/post-new.php, instead of
    http://mainsite.com/subsite/wp-admin/post-new.php. when clicked a WordPress message error comes up, which states you do not currently have privileges on this site, etc....

    Second error, which is possibly related. when I login as the Super admin and goto My sites. All the subsites are shown.

    The sites with the domain mapped show the mapped-domain.com/wp-admin, which is how it should work but the non mapped domains show mainsite.com/wp-admin on the dashboard links instead of mainsite.com/subsite/wp-admin?

    Any thoughts?

  2. What plugins are you running?

  3. John Bunka
    Member
    Posted 2 years ago #

    Ipstenu, thanks for the reply.

    All the active network ones are:
    BuddyPress, Domain Mapping plugin - Incsub version, Anti-splog,Google Analytics, Google Maps, Pro Sites, Simple Sitemaps for Multisite, Shortcodes in Sidebar Widgets, WordPress.com Custom CSS, WPMU Update Notifications

    Main Site active plugins
    Comments Plus, Floating Social, Akismet, Genesis Connect, Genesis Simple Sidebars, Gravity Forms, Jetpack, Social Profiles widget, Strx Zurb CSS3 Buttons, Testimonials Widegt, WP Overview (lite) MU

  4. Domain Mapping plugin - Incsub version

    Gotta start there, man. Go to wpmudev and ask them about their plugin. It's behind a paywall and we can't really help you unless we have the plugin (I use Donncha and Ron's myself)

  5. John Bunka
    Member
    Posted 2 years ago #

    I already have and no one knows, maybe I will try donncha's

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags