WordPress.org

Ready to get started?Download WordPress

Forums

BuddyPress Group Email Subscription
[resolved] Subscription status not applied to new group members (6 posts)

  1. Vernon Fowler
    Member
    Posted 11 months ago #

    DEFAULT SUBSCRIPTION STATUS Group admins can choose one of the 5 subscription levels as a default that gets applied when new members join.

    For my site, BP 1.7.2 and plugin version 3.3.3, the group default subscription setting is not applied to members when they join.

    If this one glitch can be resolved I will be one very happy camper. Is it just me or is anyone else noticing the same problem? http://wordpress.org/plugins/user-switching/ is a handy plugin if you wish to test your own setup.

    http://wordpress.org/extend/plugins/buddypress-group-email-subscription/

  2. ydubois
    Member
    Posted 7 months ago #

    For me, no setting at all is applied to new users. Not even the default email alert settings of the plugin. User need to save their settings (click on the save button) for their settings to be initialized at all.

  3. Vernon Fowler
    Member
    Posted 7 months ago #

    Now up to BP 1.8.1 and plugin version 3.4 with the same issue still lingering. Any assistance greatly appreciated as both our groups and group moderators are growing in number and our communities can become much more autonomous once this works...

  4. r-a-y
    Member
    Plugin Author

    Posted 7 months ago #

    @vernonfowler - Sorry to hear that you are still having this problem.

    Contact me with your site details so I can look into it.

  5. r-a-y
    Member
    Plugin Author

    Posted 7 months ago #

    I just took a look at Vernon's install and it was due to a plugin conflict.

    The "BuddyPress Group for Community Admins and Mods" plugin was hijacking the group member data when a member joins a group.

    Since that plugin is not cleaning up after itself properly, this affected how GES is able to provision the correct subscription status to new group members.

  6. Vernon Fowler
    Member
    Posted 7 months ago #

    Unfortunately BuddyPress Group for Community Admins and Mods hasn't been updated for quite some time now. With that plugin deactivated now, Group Email Subscription appears to be working fine - hooray!

    Thanks @r-a-y for taking the time to give support for this edge case. Greatly appreciated.

Reply

You must log in to post.

About this Plugin

About this Topic