WordPress.org

Ready to get started?Download WordPress

Forums

Subscribe To Comments Reloaded
[resolved] subscription redirects to a strange "category" page (12 posts)

  1. mattiafrigeri
    Member
    Posted 1 year ago #

    I don't know why, but this plugin doesn't work in my theme, which is a very simple theme. I wrote 2 times to the author but neve got an answer.

    When someone tries to subscribe or when the admin tries to manage subscriptions, it redirects me to a strange "category" page.

    Hope someone can tell me why:

    http://www.mattiafrigeri.it/articoli/grafica/photoshop-creare-gruppi-guide-calamitate-custom-guides/

    Try to press "iscriviti" button at the end of the page

    http://wordpress.org/extend/plugins/subscribe-to-comments-reloaded/

  2. mbrsolution
    Member
    Posted 1 year ago #

    Hello mattiafrigeri have you tried the latest version?

    Kind regards

  3. mattiafrigeri
    Member
    Posted 1 year ago #

    Hi friend,

    thanks for updating me. Yes I just tried, and still it redirects the user to the category template... You can try and click "iscriviti" at the end of every article... ;(((

    http://www.mattiafrigeri.it/

    Do you have any idea?

  4. mbrsolution
    Member
    Posted 1 year ago #

    Hello did you create a page with the name Comment Subscriptions? Also make sure that you are using the correct permalink from your WordPress installation. From what I see your URL is as follow

    /comment-subscriptions/?srp=98&sra=s

    What is ?srp=98&sra=s?

    If you set up your permalink correctly you will fix your issue.

  5. mattiafrigeri
    Member
    Posted 1 year ago #

    Hi,

    and thanks again.
    No, I did not create a page with the name "Comment Subscriptions"...

    And that string, "?srp="98...", I don't know where it is from...
    The plugin permalink is correct, it has no strange parameters inside the settings.

    You can see that because if you "clean" the URL directly in the browser, nothing changes unfortunately ;((((

  6. mbrsolution
    Member
    Posted 1 year ago #

    Hi sorry about the information above.....this string ?srp=98&sra=s is created by the plugin because I just closely checked my subscribe link.

    Can you create a page with a name Comment Subscriptions and see if that helps you.Of course in your case it will have to be translated to Italian.

    I just checked your website again and this is what I can see. Your link when you click on iscriviti the URL is /gestisci-iscrizione/?srp=726&sra=s if you remove the / and leave the URL as /gestisci-iscrizione?srp=663&sra=s it works. So what I can see is that your settings must be wrong or something is placing the / in the URL that is why it is going to a different URL.

    Also can you check in your WordPress Admin >> Settings >> Permalinks and see what you have setup as your permalinks.

    Kind regards

  7. mattiafrigeri
    Member
    Posted 1 year ago #

    Hi,

    yes I tried to create that page, but it doesn't solve anything, plus you don't have to do it, because it must not exist!

    I saw that if I remove the "/" from the URL, something automatically puts it back again, and probably that's the cause of my issue. How did you manage to remove it definitely?!
    Probably it's something I put in the .htaccess file...

    Anyway, I found a solution!
    It has happened casually, I added "login" at the end of the URL in the settings, like:

    "/gestisci-iscrizioni/login"

    and it seems to work!

    What do you thing about it? ;) Does it work now for you?

  8. mbrsolution
    Member
    Posted 1 year ago #

    Hi,

    In my case I created the page and it works well for me. If I disable or delete the page when someone subscribes to my blog the e-mails are not sent to either the subscriber or the administrator.

    This is the reason why I have created the page and it works superbly for me.

    Thank you for sharing your information with me.

    I am not sure if adding the /login to the page is the right way to go about it. So far I have not read anywhere in the Support Forum anyone adding the /login to the page.

    If you need more information please let me know.

    Kind regards

  9. mattiafrigeri
    Member
    Posted 1 year ago #

    Hi,

    don't you think that the need for creating a page that doesn't exist is some kind of bug? I have another site, where this plugin works perfectly without nothing at all of all that me and you have done... it just works!

    I suspect my issue comes from something I manually put time ago inside ".htaccess", not to have different version of URLs for the same page (or something similar...). When I have time I'll check.

    Btw, I am not sure that writing "login" inside the settings is my cure, maybe I could have written anything else... I'll check that too.

    Thank you for your precious help... I won't mark this as solved, because someone else may come out with new ideas!

  10. mbrsolution
    Member
    Posted 1 year ago #

    Hello,

    You are most welcome and I agree with you it should be almost a straight forward plugin without having to configure too much I guess.

    I hope one of the developers comes on board and shares some light into this matter to help us ;)

    I look forward to an answer.

    Kind regards

  11. mbrsolution
    Member
    Posted 1 year ago #

    Hello someone in another support thread posted this code. You might want to check for yourself.

    Kind regards

  12. mattiafrigeri
    Member
    Posted 1 year ago #

    Thanks mate for your support I'll give that a read!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic