WordPress.org

Ready to get started?Download WordPress

Forums

Coming Soon / Maintenance mode Ready!
[resolved] [closed] Subscriber emails (22 posts)

  1. chetanchopra
    Member
    Posted 9 months ago #

    I have filled all the details for subscriber emails and subscriptions. But if someone tries to put in their email address it keeps loading and does nothing. Please help me out. http://www.recruitro.com

    http://wordpress.org/plugins/coming-soon-maintenance-mode-ready/

  2. Ready! Developer
    Member
    Posted 9 months ago #

    Hello.
    I checked it on http://www.recruitro.com/ , added email "testing_from_ready_suport@mail.com" - and it show me "Thank you! We will surely let you know when the community is open for subscription.", so I can't see any problems.

    Regards,
    Alexey.

  3. jpdeboer
    Member
    Posted 9 months ago #

    Exactly the same here at http://djgustino.com.

    Please help me out??!!

    Regards,
    Jeroen

  4. Ready! Developer
    Member
    Posted 9 months ago #

    Can you enable php error reporting on your site? You can do it from your hosting account, or ask you hosting support. If so - I will be able to look into error - and fix it.

    Regards,
    Alexey.

  5. jpdeboer
    Member
    Posted 9 months ago #

    Will ask and get back to you.
    Thanks!!

    Ragards,
    Jeroen

  6. jpdeboer
    Member
    Posted 9 months ago #

    Hi Alexey,
    Does a log file do the trick?
    Or do you really need error reporting on the site?

    Regards,
    Jeroen

  7. Ready! Developer
    Member
    Posted 9 months ago #

    Hello.
    I need php error(s) message(s) (please note - not server - apache or other, exactly - php errors), better - to enable errors reporting, but if it better for you do not do this and you can provide me with errors from log file - let's try to go this way.

    Regards,
    Alexey.

  8. jpdeboer
    Member
    Posted 9 months ago #

    Hi Alexey,
    Thanks for helping out. Unfortunately the hostingprovider does not like to enable php error messages, so I will have to stick to using the error log file. Can I mail you the log file? What's the emailaddress I can send it to?

    Kind regards,
    Jeroen

  9. Ready! Developer
    Member
    Posted 9 months ago #

    Hello.
    Just provide me with few last errors from this log file here.

    Regards,
    Alexey.

  10. Can I mail you the log file? What's the emailaddress I can send it to?

    That's really discouraged as in people have abused that in the past. Please keep support on the forums.

    For posting log data in large amounts please use pastebin.com instead and just post the link to the paste.

  11. jpdeboer
    Member
    Posted 9 months ago #

    From moment of subscribing last week I see this line a lot of times:

    [Wed Oct 02 14:39:51 2013] [error] [client 2a01:7c8:eb:0:95:170:70:59] FastCGI: server "/usr/local/php54/bin/php-cgi" stderr: PHP message: PHP Warning: ignore_user_abort() has been disabled for security reasons in /sites/djgustino.com/www/wp-cron.php on line 12

    Also this one:

    [Wed Oct 02 13:03:24 2013] [error] [client 213.125.83.75] FastCGI: incomplete headers (0 bytes) received from server "/usr/local/php54/bin/php-cgi", referer: http://www.djgustino.com/wp-admin/theme-editor.php?file=index.php&theme=deepfocus

    Does this help?

    Also today after testing in another laptop I see Thank you message after subscribing, but I get no email confirmation.

  12. Ready! Developer
    Member
    Posted 9 months ago #

    No, this didn't help. But if now you see responce from server about "Thank you..." - maybe problem is gone? Did you checked email-to option in admin -> Ready! Coming soon page options -> SUbscribe tab? Is there your email? Did you checked spam folder? does your server send correct emails? About last question - if you don't know how to do this - ask your hosting provider.

    Regards,
    Alexey.

  13. jpdeboer
    Member
    Posted 9 months ago #

    I checked email-to option in admin -> Ready! Coming soon page options -> SUbscribe tab. All emailadresses I used (total of 4 on different servers and domains), also yours, are there. But not confirmed, because there is no email sent with confirmation link.

    Reply of the hosting provider is this:

    On our hosting platform for safety reasons outgoing traffic towards port 25 (SMTP) is locked. This meens that PHP scripts that make use of pfsockopen() to send mail will not work.

    If you use a CMS such as Joomla, you can use the option "PHP mail function" which can be selected via the user interface of Joomla itself. More information about setting up your server in Joomla can be found here: http://docs.joomla.org/Help15:Screen.config.15 # server_settings

    When you use your own scripts you can use the mail() function to send the email . This can be done with the following structure:

    mail ("support@transip.nl", "subject", "body",
    "From: support@transip.nl", "-fsupport transip.nl @");

    For more information about using this function, see the following location: http://php.net/manual/en/function.mail.php:

    I'm lost .....
    Does this help to figure out what goes wrong?

    Thanks again for helping out.

    Kind regards,
    Jeroen

  14. Ready! Developer
    Member
    Posted 9 months ago #

    Sure, this help. Your hosting provider sent you a message with clarification about Joomla. Please send them message, that you are using wordpress, and you also have this problem, and ask them - what should you do with wordpress to activate email functionality on your server.

    Regards,
    Alexey.

  15. jpdeboer
    Member
    Posted 9 months ago #

    Hosting provider tells me for WordPress it's the same.
    Do you know what I should change where?

    Kind regards,
    Jeroen

  16. Ready! Developer
    Member
    Posted 9 months ago #

    So, as I understand, your hosting provider want you to go to code in wordpress core, and make changes according to their (hosting) requirements? If so - this is not plugin problems. This is problems of your hosting provider. If they knew what they done when disabling this functionality on server - they should know how to fix this in their customers (your) sites.

    Regards,
    Alexey.

  17. mrlimp
    Member
    Posted 9 months ago #

    Excellent plugin, thank you!

    On the email sign-up I have the same problem here... I get the loading graphic that spins continuously if I am logged in as admin or not, however, when I switch to another computer the subscribe form works correctly. Confirmation emails are delayed, then found in my spam folder with from address like

    Where does the email from address get set?

  18. mrlimp Unless you are on the same server with the same plugins, theme, PHP version, Apache configuration, PEAR modules as the OP then per the forum welcome please start your own topic instead.

    http://wordpress.org/support/plugin/coming-soon-maintenance-mode-ready#postform

  19. jpdeboer
    Member
    Posted 9 months ago #

    We're changing hostingprovider. Didn't want to think with us and found several discussions online about this provider giving problems with automatic updates.

    Thanks all for helping out!

  20. Ready! Developer
    Member
    Posted 9 months ago #

    Good luck for you with your other hosting provider. Please mark this topic as resolved if now this is working good.

    Regards,
    Alexey.

  21. jpdeboer
    Member
    Posted 9 months ago #

    Sorry Alexey, but it is not my topic, so I can not close it.

    Thanks again!!

    Kind regards,
    Jeroen

  22. chetanchopra
    Member
    Posted 9 months ago #

    Shall mark it as resolved since my issue is resolved as well. Thanks.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags