WordPress.org

Ready to get started?Download WordPress

Forums

subscribe2 plugin help (9 posts)

  1. sintax
    Member
    Posted 8 years ago #

    I have installed "subscribe2" and have everything up and running except I have encounted one problem. I customized my Email templates (Options > Subscribe2) but when I create a new post and click on the link to "Mail subscribers"... that is when the trouble starts.

    I was under the impression that the Email template I set up would be used. Instead I get Subject box pre-filled in "A message from [blog name]" and a big empty text area below it. If I leave that area blank and send the message, nothing happens. If I put a few words in the (like "this is a test") I get an Email with those words. Shouldn't my blog post and stuff be sent out instead?

    Can anyone help me? I am new to WP and the developer of the plugin says he does not provide support. Thanks!

  2. FruitFly
    Member
    Posted 8 years ago #

    Suscribe2 automatically sends a notification (using the template) to anyone who is subscribed as soon as you publish the post. Try subscribing yourself using a couple of other email addresses (get a Yahoo or Gmail one if you don't already have 'em), then make a test post. (If you don't have any subscribers, it doesn't send anything out if I'm remembering correctly.) You should get that email, both to your admin email account and all subscribed email accounts.

    The link to send a message to subscribers that you're clicking on is a separate feature - just a way for you to send a note to all subscribers at once (not a blog post).

    Does that make sense? :)

  3. sharkweb
    Member
    Posted 8 years ago #

    Hi all,

    I have just installed "subscribe2" and everything looks ok, also I have the latest version of wordpress. I tested the new plugin, with a couple of emails address, sending email and writing post, and the only email who got the messages that I sent is the admin email... the other emails no. So if u can help me or give me any idea could be nice, everything is working except this.

    thx.

  4. FruitFly
    Member
    Posted 8 years ago #

    shark - though this probably should have its own thread, I'll see if I can help.

    Are you sure all the email addresses you've got subscribed are confirmed? (You either have to click the link in the confirmation email that should have been sent, or make sure they're in the confirmed column)

    Are they subscribed to all categories?

  5. sharkweb
    Member
    Posted 8 years ago #

    FruitFly.. thx for your answer.

    I subscribed one email from the admin, and also is confirmed, it is on the middle column, just to check if when I send an email I will recieve it, but nothing happened. Then, also I tried using the form from my blog site, but there is no email confirmation sent.. also this last one is confirmed.

    I haven't selected any category to be excluded, and I selected the option to "Allow registered users to subscribe to excluded categories?"

    So I don't know what is happening!! :(

    For your time and help thx!

  6. FruitFly
    Member
    Posted 8 years ago #

    Honestly, I'm not sure what would be the problem. I tried subbing to your site, and sure enough, I didn't get a confirmation email. I haven't hit this snag myself in using subscribe2, so it's really hard for me to help.

    This is an example of why Skippy stopped offering support I think - the variables with your host for mail are so great, that it's hard to be able to tell what the problem is, without working directly with your server and such. (And even then I'd only barely know what I was doing...)

    Sorry I can't be of more help.

  7. Laz
    Member
    Posted 7 years ago #

    2 Quick Questions:

    (1) How can I add a "first name" field to Subscribe2?

    [I'm guessing I must change the codes in 2 places in subscribe2.php

    (a) line 75: "$this->form = "<form method='post' action=''>" . __('Your email:', 'subscribe2') . " <input type='text' name='email' value='' size='20' /> 
    <input type='radio' name='s2_action' value='subscribe' checked='checked' /> " . __('subscribe', 'subscribe2') . " <input type='radio' name='s2_action' value='unsubscribe' /> " . __('unsubscribe', 'subscribe2') . "  <input type='submit' value='" . __('Send', 'subscribe2') . "' /></form>\r\n";
    "

    And line 141: "$sql = "CREATE TABLE $this->public ( email varchar(64) NOT NULL default '',"]

    Anywhere else? (And please show me how to add the FirstName fields - I don't want any parse errors cause I'm a newbie!)

    (2) How can I place the form code in a static page?

    [Right now, I want to add the <!--subscribe2--> or actual form html right on my static index page - my WP blog resides in /blog/ folder not where my index is.]

    I already tried adding the form html then later the <!--subscribe2--> code with no success.

    This plugin does exactly what I need (excluding categories, etc...), so its' definetly what I'll use, if I can only figure out the above with your help.

    Thanks in advance!
    Laz

  8. jaks
    Member
    Posted 7 years ago #

    I'm trying to figure out how to remove the HTML and Full post options from Subscribe2.

    Anyone have any ideas?

  9. Novac
    Member
    Posted 7 years ago #

    I tried subbing to your site, and sure enough, I didn't get a confirmation email.

    I had this same problem on my site, too.

    I noticed in the code that the three calls to wp_mail have '@' in front of them. Since I am clueless about the purpose of @ in front of functions, so I unwisely removed it before all three function calls. The result was that my e-mails were now sent out for subscriptions and posts.

    Since I have no idea what I actually did when I removed the at symbol, I deactivated the plugin on my site.

    What repercussions does this have on the plugin/site?

Topic Closed

This topic has been closed to new replies.

About this Topic