WordPress.org

Ready to get started?Download WordPress

Forums

Subscribe2
[resolved] Subscribe2 6.0 upgrade with warning messages (5 posts)

  1. MDBlogs
    Member
    Posted 3 years ago #

    I stupidly did the auto-upgrade for Subscribe2 without going to the Plugin site to look for possible problems. (won't do this again w/o checking)

    When I uploaded, this is the message I got:

    Enabling Maintenance mode…

    Updating Plugin Subscribe2 (1/2)
    Subscribe2 updated successfully. Show Details.

    Warning: fopen(/home/content/w/e/b/myloginnamehere/html/maternal-dementia/wp-content/plugins/subscribe2/counterwidget.php) [function.fopen]: failed to open stream: No such file or directory in /home/content/w/e/b/myloginnamehere/html/maternal-dementia/wp-includes/functions.php on line 4165

    Warning: fread(): supplied argument is not a valid stream resource in /home/content/w/e/b/myloginnamehere/html/maternal-dementia/wp-includes/functions.php on line 4168

    Warning: fclose(): supplied argument is not a valid stream resource in /home/content/w/e/b/myloginnamehere/html/maternal-dementia/wp-includes/functions.php on line 4171
    Updating Plugin (2/2)
    updated successfully. Show Details.

    Disabling Maintenance mode…

    All updates have been completed.

    It says successfully updated, but the warning messages don't indicate that it was entirely successful. And I'm not sure if these issues render the Plugin inoperable, or if it's just a bug that will be fixed with the next version. In the meantime, other than trying to dig up the previous version and reinstalling, any ideas for a fix?

    As always, I'm grateful to the people in this community who can answer questions.

  2. mattyrob
    Member
    Plugin Contributor

    Posted 3 years ago #

    @MDBlogs,

    The location of that counterwidget.php file changed in the upgrade. The error is warning you that the file could not be found.

    The counter widget is now part of the main plugin and not a separate plugin file.

    The upgrade process should have worked okay but the error messages are telling you that the old plugin file disappeared before it was deactivated. The should not be a great concern.

  3. MDBlogs
    Member
    Posted 3 years ago #

    Thanks -- I'd already replaced it with 5.9. But I'm grateful for your help, and for the Plugin. (I did make a small donation to appreciate the time you're taking on this.) Should I reload and ignore the warning messages or wait for 6.1?

  4. mattyrob
    Member
    Plugin Contributor

    Posted 3 years ago #

    @MDBlogs,

    6.1 shouldn't be too long a wait but you may get the same message upgrading from 5.9 to 6.1.

  5. MDBlogs
    Member
    Posted 3 years ago #

    Okay then, I'll ignore the warning messages next time. Thanks for your reassurance.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags