WordPress.org

Ready to get started?Download WordPress

Forums

SendPress Newsletters
[resolved] Subscribe widget not working (4 posts)

  1. sleander
    Member
    Posted 4 months ago #

    I found some threads describing the same problem, but no solution was posted. Below is my system info, I have deactivated/reactivated the plugin, removed and reinstalled the widget, still doesn't work. I get the same behavior others have described - entering new subscriber info and clicking submit just reloads the page and nothing happens (subscriber is not added).

    Thanks for your help!

    Steve

    ### Begin System Info ###

    ## Please include this information when posting support requests ##

    Multi-site: No

    SITE_URL: XXX
    HOME_URL: XXX

    SP Version: 0.9.9.3
    WordPress Version: 3.8.1

    Platform: Windows
    Browser Name: Firefox
    Browser Version: 27.0
    User Agent String: Mozilla/5.0 (Windows NT 6.1; WOW
    64; rv:27.0) Gecko/20100101 Fire
    fox/27.0

    Database Tables:
    wp_sendpress_subscribers_event OK
    wp_sendpress_report_url OK
    wp_sendpress_subscribers_status OK
    wp_sendpress_subscribers OK
    wp_sendpress_list_subscribers OK
    wp_sendpress_queue OK

    Sending Method: SendPress_Sender_Website

    PHP Version: 5.3.3-7.3+hw2
    MySQL Version: 5.5.28-1
    Web Server Info: Apache

    PHP Memory Limit: 256M
    PHP Post Max Size: 8M

    WP_DEBUG: Disabled

    WP Table Prefix: Length: 3 Status: Acceptable

    Show On Front: posts
    Page On Front: #0
    Page For Posts: #0

    Session: Disabled
    Session Name: PHPSESSID
    Cookie Path: /
    Save Path: /var/lib/php5
    Use Cookies: On
    Use Only Cookies: On

    UPLOAD_MAX_FILESIZE: 2MB
    POST_MAX_SIZE: 8MB
    WordPress Memory Limit: 40MB
    WP_DEBUG: Off
    DISPLAY ERRORS: N/A
    FSOCKOPEN: Your server supports fsockopen.

    ACTIVE PLUGINS:

    Delete All Comments: 1.0
    Facebook Like Box: 2.7
    Jetpack by WordPress.com: 2.9.2
    SendPress Newsletters: 0.9.9.3
    TinyMCE Advanced: 3.5.9.1
    UpdraftPlus - Backup/Restore: 1.8.12

    CURRENT THEME:

    Classic Chalkboard: 2.6

    ### End System Info ###

    https://wordpress.org/plugins/sendpress/

  2. itdoug
    Member
    Plugin Author

    Posted 4 months ago #

    I can offer you a couple of suggestions. Some people who have had issues with the widget have found better success using the sign-up short code in a text widget. You can read more about how to use the short code in this knowledgebase article.

    https://sendpress.com/support/knowledgebase/how-to-use-the-sign-up-shortcode/

    There are also some settings under settings and then advanced that can affect how the widget operates. You can try toggling on some of the checkboxes for CSS and Ajax. It may help resolve compatibility issues with your theme.

    The last thing (or maybe the first thing) you could try is to just resave the widget settings. Sometimes during upgrade some settings do not get committed. At the same time you should make sure that you do have one public list and that list is selected in the sign-up widget settings.

  3. sleander
    Member
    Posted 4 months ago #

    Turning of Ajax fixed it. Thanks!

  4. itdoug
    Member
    Plugin Author

    Posted 4 months ago #

    Awesome!

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.