WordPress.org

Ready to get started?Download WordPress

Forums

Subscribe to Comments Works, Subscription Manager Does NOT (2.8.6) (9 posts)

  1. MiOtraCosa
    Member
    Posted 4 years ago #

    I realize that neither the 2.1.2 version nor the 2.1.3 (a recently published patch version) state that they are compatible with 2.8.6 (just released a couple days ago); however, many people have reported success with slightly older version. So I thought I would give this a try.

    I tested both versions of this plug-in on a 2.8.6 version of WP and on a 2.8.5 version as well. In all cases the result was the same. The subscription parts worked fine. The subscription emails send out as well when tested; however, the Subscription Manager links made available to subscribers and to post authors do not work. When clicked they send all back to the homepage.

    If I directly access this URL (http://www.hairextensionsreviews.com/?wp-subscription-manager) when logged in as the owner/administrator then I am able to successfully access the Subscription Manager. But if I use any of the provided links on the bottom of the post's comments I am put on the homepage, whether logged in as the post author, site administrator, or just a commenter.

    I also feel like something else is missing. The plug-in does not seem to have an "options", "settings", or "configurations" panel. When I view it under "Manager Plugins" I see only links to Mark's and Scriptygoddess' websites. The documentation makes a reference to such an options page, but I can't find this:

    "text can all be customized in the options (Options -> Subscribe to Comments)."

    Since this has worked for so many, I tend to think that my minor version upgrade cannot be the problem. Please help me figure out what I am missing. I have not customized the plug-in at all. If you have a moment, please check out the results on my testing ground website. Thanks in advance for any feedback!

    http://wordpress.org/extend/plugins/subscribe-to-comments/

  2. Nasul
    Member
    Posted 4 years ago #

    For your information Subscription Manager never worked for me when using wp 2.8.x, something is wrong with the js.
    Another problem is this "Pingbacks are subscribed" http://wordpress.org/support/topic/320501?replies=5

  3. MiOtraCosa
    Member
    Posted 4 years ago #

    I guess I am really discussing this issue is two places now. Here is what I just posted on the other forum topic:

    I just dug some more on this issue and I think I know what the problem is. My "Manage Your Subscriptions" URL comes over like this:

    http://www.hairextensionsreviews.com/?wp-subscription-manager=1&email=echo4dr%40yahoo.com&key=0d21c1739aa7eabff8221b7605a26931&ref=http%3A%2F%2Fwww.hairextensionsreviews.com%2Farticles%2Fgeneral-articles%2Fwhat-is-hand-tied-hair%2Fcomment-page-1%2F

    If I chop off the &ref=http%3A%2F%2Fwww.hairextensionsreviews.com%2Farticles%2Fgeneral-articles%2Fwhat-is-hand-tied-hair%2Fcomment-page-1%2F part of the string then the URL is good.

    This also is true of the URL made available to the author, which is:
    http://www.hairextensionsreviews.com/?wp-subscription-manager=1&ref=http%3A%2F%2Fwww.hairextensionsreviews.com. If I access this I get nothing, but if I take off the &ref=http%3A%2F%2Fwww.hairextensionsreviews.com string then it works just fine. Its ugly, but it works.

    So.... what is the point of that "ref" variable? Removing it seems to fix things considerably. Does anyone else have trouble with this? Do theirs look differently? I am very curious before I start creating my own "new version" of this plug-in.

    Thanks!

  4. MiOtraCosa
    Member
    Posted 4 years ago #

    I didn't think of any valuable reason to retain the "ref" query argument / variable in the Subscription Manager and no one spoke up here or in the other topic. So I went in and just commented-out the following line in the "manage_link" function of the plugin:

    //$link = add_query_arg('ref', rawurlencode('http://' . $_SERVER['HTTP_HOST'] . attribute_escape($_SERVER['REQUEST_URI'])), $link);

    After I did this, the Subscription Manager URLs listed on the posting worked for me; for both my test user and for the article author/site administrator.

    I would like to declare success, but I later discovered the purpose of the "ref" variable. It feeds the "Return to the page you were viewing" URL on the Subscription Manager. It would seem that the value expected here is the part of the URL following the "http://website.com/" portion, like this (http://www.hairextensionsreviews.com/?wp-subscription-manager=1&email=echo4dr%40yahoo.com&key=0d21c1739aa7eabff8221b7605a26931&ref=articles%2Fgeneral-articles%2Fwhat-is-hand-tied-hair%2Fcomment-page-1%2F). Perhaps, the culprit is one of the following:

    • my site's permalink configuration is not standard
    • WP 2.8.x does something different such that it feeds this plugin a permalink different than is expected
    • WP 2.8.x variables differ slightly so that it prevents the plugin from parsing the permalink properly

    I will dig on this more, but I wanted to share this for now, hoping that someone might have some input.

  5. MiOtraCosa
    Member
    Posted 4 years ago #

    OK, I think I fixed my issue without removing any functionality. I also made it compatible with my theme.

    Code changes for Subscription Manager fix:

    Original code line from "manage_link" function:

    $link = add_query_arg('ref', rawurlencode('http://' . $_SERVER['HTTP_HOST'] . attribute_escape($_SERVER['REQUEST_URI'])), $link);

    MODIFIED code line from "manage_link" function:

    $link = add_query_arg('ref', rawurlencode(attribute_escape($_SERVER['REQUEST_URI'])), $link);

    In order to make this plugin compatible with my theme (after checking the option for "Use custom style for Subscription Manager") I had to replace the first <div class="wrap"> of the Subscription Manager HTML code with <div id="content">. Also I had to take is closing </div> tag and move it below the closing </div> tag of the "Adavanced Options section:

    an excerpt

    </fieldset>
    
    			<?php } ?>
    	<?php } //end if not in do not mail ?>
    
    	</div> <!-- class="wrap" -->
    
    	</div> <!-- id="content" -->
    
    	<?php if ( $sg_subscribe->standalone ) : ?>
    	<?php if ( !$sg_subscribe->use_wp_style ) :
    	echo $sg_subscribe->after_manager;

    I need to test this more, but this appears to have corrected my problems. Any comments would be appreciated.

  6. MiOtraCosa
    Member
    Posted 4 years ago #

    Just to continue my one-way conversation here...

    I think I have it all configured and working/looking just the way I like now. You can have a look by visiting my test grounds at http://www.hairextensionsreviews.com/. Feel free to leave a comment and try it out, if you are curious about this plugin or my tweaks to it. I will approve it within 24 hours and then you should be able to get your email updates.

  7. philippetrov
    Member
    Posted 4 years ago #

    The 2.1.2 version worked fine for me at cphpvb.net. Just few modifications was needed for translation.

  8. Alexander Gieg
    Member
    Posted 4 years ago #

    @MiOtraCosa: Thank you. I applied your suggested changes to my copy of the unofficial 2.1.3 and I will see if it causes some problem in my setup, which was working fine with 2.1.2, in which case I'll report here.

  9. Alexander Gieg
    Member
    Posted 4 years ago #

    Okay, here I am. While almost everything I did following instructions in these threads helped improve significantly the unofficial 2.1.3 version, one change didn't work well: changing the divs around. It caused problems in positioning the sidebar and footer on the Swift theme, so I reversed this change and with the divs where they originally where everything is working perfectly.

    My advice to those implementing these changes is thus that you apply everything, except for the div change. If you blog works and render correctly, that's it. Only if something renders strangely try changing divs around.

Topic Closed

This topic has been closed to new replies.

About this Topic