WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form 7
Submit Not Working In Firefox or Chrome, Does Work In Safari (8 posts)

  1. pmdworks
    Member
    Posted 8 months ago #

    Hello,

    We've got the latest version of Contact Form 7 installed (3.5.4) running on WordPress 3.7.1, testing on Mac 10.8 Mountain Lion.

    When a user fills out a form and clicks on the Submit button the form is submitted properly in Safari 6.1, but in Firefox 25.0.1 and Chrome 31.0.1650.57 you just see the spinning circular arrows and there is no feedback to the user that the form was successfully submitted.

    The FAQ says this could be a theme conflict, yet it works fine in Safari so not sure what is up, please help! Thanks.

    http://wordpress.org/plugins/contact-form-7/

  2. pmdworks
    Member
    Posted 7 months ago #

    Update, it does appear that the form submissions are actually sending from Firefox and Chrome even though the user does not get any feedback, just the spinning circular arrows as noted above. Its not clear if the user must wait on the page a certain amount of time before giving up as to wether or not the message is sent. Its really important for our users to know that their message will be delivered to us, hopefully this can be fixed in a future release. Thanks.

  3. Pioneer Valley Web Design
    Member
    Posted 7 months ago #

    Just want to chime in that I have had multiple customers call and note same issue:

    We've got the latest version of Contact Form 7 installed (3.5.4) running on WordPress 3.7.1, testing on Mac, just gives a generic try again error...Works from W8, W7, WinXP, Android phone (multiple browsers tested on each)...appears to be Mac only related.

  4. buzztone
    Member
    Posted 7 months ago #

    If you are able to include a link to your Contact Form 7 form, others here may be able to offer more assistance.

  5. Pioneer Valley Web Design
    Member
    Posted 7 months ago #

    If on a Mac, feel free to follow my link. Please, would be interesting to be disproven (of course the auth is seemingly quiet on this)

  6. buzztone
    Member
    Posted 7 months ago #

    @Pioneer Valley Web Design - I have just tested the link you provided using firefox 25.0.1. Recieved message "Your message was sent successfully. Thanks." with no javascript errors. Your Contact Form 7 form appears to be running as expected.

  7. Pioneer Valley Web Design
    Member
    Posted 7 months ago #

    I received your 'foo' email. What version of Mac OS are you using? There must be something there about this, I received a call from a prospective customer that they had attempted to use the CF from a Mac with Chrome or Safari unsuccessfully. I am not a Mac user so I thought I would review here and saw similar posts (and this very recent one)...

  8. sharmtripsstore
    Member
    Posted 7 months ago #

    @pmdworks
    my also face this problem and till now cant fix it

Reply

You must log in to post.

About this Plugin

About this Topic