WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form 7
submission confirmation issue (9 posts)

  1. Rob Falla
    Member
    Posted 6 months ago #

    My form (http://www.damagedoctor.co.uk/request-a-quote/) works in that it always submits to the database and sends the email but the feedback to users is at best inconsistent.

    Example Use:
    User completes form and clicks or taps "Send"
    Expected result:
    1. CF7 sends email and saves data to CFDB
    2. Form page reloads with user feedback message "Your message was sent successfully. Thanks."
    Observed Result:
    1. as expected, regardless of the browser of device.
    2. as expected for Chrome
    2. gives no user feedback in Safari on the iPad or Firefox on PC.

    Impact:
    Users are clicking the "Send" button repeatedly, some time up to 20 times, because they are assuming the form submission has simply not happened. Without feedback they assume there is an issue with the button and keep clicking.

    Steps taken so far:

    I have attempted to insert a redirect using the recommended on_sent_ok hook:

    on_sent_ok: "location = 'http://damagedoctor.co.uk/thankyou';"

    But that didn't help.

    I am not at all bothered about analytics at this stage. I am interested in the user experience of the site. Many thanks for any help you can offer.

    http://wordpress.org/plugins/contact-form-7/

  2. volution
    Member
    Posted 6 months ago #

    I have a similar problem. If all required information is filled in and it the submit button. it generates the two emails but back at the page. The spinner keeps spinning and doesn't load Your message was sent successfully. Thanks."

    If I don't put the wrong in phone The spinner keeps spinning and doesn't reload an error page.
    using 3.8.1

  3. volution
    Member
    Posted 6 months ago #

  4. kbellagio
    Member
    Posted 6 months ago #

    I tried the form and it worked for me.

  5. Rob Falla
    Member
    Posted 6 months ago #

    Any thought on my issues?

    I've identified the environment where it works and where not.

    Any guidance would be most appreciated.

  6. buzztone
    Member
    Posted 6 months ago #

    @volution - As per the Forum Welcome, please post your own topic.

    Posting in an existing topic prevents being able to track issues by topic. Added to which, your problem - despite any similarity in symptoms - is likely to be completely different.

  7. buzztone
    Member
    Posted 6 months ago #

    Intermittment nature of problem indicates that form is sometimes not sending.

    Getting info into DB is usually not a problem.

    Sending email can be - depends heavily on your particular WP install - See Contact Form 7 Email Issues.

    Working on Chrome and not on other browsers is also indicative of a Javascript Conflict - there is a link on Contact Form 7 Email Issues - that covers Javascript Conflicts.

    Using on_sent_ok is likely to make things worse rather than better.

  8. Rob Falla
    Member
    Posted 6 months ago #

    This is an odd issue because it is only intermittent in the sense that it works as expected in one browser (Chrome) but not for other browsers.

    Has anyone encountered this issue who also resolved it?

    If so, I'd appreciate hearing from you about how you managed to resolve it.

  9. Rob Falla
    Member
    Posted 6 months ago #

    Update:

    I still have not resolved this issue.

    I will continue working on it when time allows and come back with the solution when found.

    Hope to close this soon.

Reply

You must log in to post.

About this Plugin

About this Topic