WordPress.org

Ready to get started?Download WordPress

Forums

Submenu Items Don't Appear Even Though They Are in the Source (1 post)

  1. Lane Lester
    Member
    Posted 1 year ago #

    On this site I created a child page (Books) and added that page as a child item to the parent page's menu item (CR Bookstore) in the custom menu. I saved the menu and the selection of that menu for use (on the left).

    When I hover over the parent item's menu entry, the child does not show up as an option. Strangely, it is listed in the page code:

    <div id="nav"><div class="menu-main-container"><ul id="menu-main" class="menu"><li id="menu-item-32" class="menu-item menu-item-type-custom menu-item-object-custom current-menu-item current_page_item menu-item-home menu-item-32"><a href="http://www.cr-ministries.org/">Home</a></li>
    <li id="menu-item-81" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-81"><a href="http://www.cr-ministries.org/cr-bookstore/">CR Bookstore</a>
    <ul class="sub-menu">
    	<li id="menu-item-107" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-107"><a href="http://www.cr-ministries.org/cr-bookstore/books/">Books</a></li>
    </ul>
    </li>
    <li id="menu-item-36" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-36"><a href="http://www.cr-ministries.org/contact/">Contact Us</a></li>
    </ul></div></div>

    Based on the code I would think the child page item would be showing all the time, but it isn't.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.