WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Subdomain pages not working (3 posts)

  1. adityabajaj
    Member
    Posted 1 year ago #

    Hello,

    Today i tried to install WP under a subdirectory of an existing WP multisite. I was using the Godaddy interface to install/uninstall. I was not aware that it had already affected my base site :'(

    Fortunately, I was able to bring it back with some older files (not the real backup though).

    Now I again updated the wp-config to turn it to a Multisite. It gave me the instructions as to what needs to be copied in wp-config and web.config (windows server). After I updated these files. I was automatically able to see the sub-sites in my dashboard. The homepages of each of the subsites are working fine however if i open a post inside that subdomain it goes to my base site. During the first conversion, I chose subdomain install subdomain.maindomain.com.

    How do I get my subdomains pages back to work?

    Note: In the Network sites option, now when I go to add a new site, it gives me option to cerate subsites in subdirectory structure (NOTE that i had subdomain structure). How should i update this thing?

    Please help!

  2. adityabajaj
    Member
    Posted 1 year ago #

    An update:
    Was able to fix subdomain problem by setting false to true:
    define('SUBDOMAIN_INSTALL', true);

    However, if i am on subdomain, it appears as if not connected with the currently logged in admin dashboard. Now the pages are opening but how do i access dashboard for subdomains?

  3. adityabajaj
    Member
    Posted 1 year ago #

    Oh it was a cache issue on the subdomain's dashboard problem. I closed all browser instances and re-opened the main site now I am by default logged into subdomains dashboard as admin as well.
    Hope this servers as a casestudy for someone.

Topic Closed

This topic has been closed to new replies.

About this Topic