WordPress.org

Ready to get started?Download WordPress

Forums

Subdomain Multisite: Correct settings for upload url path? (8 posts)

  1. B_Dark
    Member
    Posted 8 months ago #

    What there must be on the main site of the multisite and on the sub domains?

    Upload Path
    Blog Upload Space
    Upload Url Path
    Fileupload Url

    This is my .htaccess

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ wp/$1 [L]
    RewriteRule . index.php [L]
    # END WordPress
    
  2. Why are you trying to edit them? The defaults should be fine!

  3. B_Dark
    Member
    Posted 8 months ago #

    because i think after moving on new server something is wrong

  4. B_Dark
    Member
    Posted 8 months ago #

    main multisite

    Upload Path: wp-content/uploads
    Blog Upload Space: empty
    Upload Url Path: empty
    Fileupload Url: http://maindomain.com/wp-content/uploads

    sub1
    Upload Path: empty
    Blog Upload Space: empty
    Upload Url Path: wp-content/uploads/sites/2
    Fileupload Url: http://sub1.maindomain.com/wp-content/uploads/sites/2

    sub2
    Upload Path: empty
    Blog Upload Space: empty
    Upload Url Path: empty
    Fileupload Url: http://sub2.com/files

    sub3
    Upload Path: wp-content/uploads
    Blog Upload Space: empty
    Upload Url Path: empty
    don't have "Fileupload Url"

    p.s: all subdomains are mapping (example: sub1.maindomain.com to sub1.com)

  5. They're supposed to be empty. Why do you think they're wrong?

  6. B_Dark
    Member
    Posted 8 months ago #

    i updated my post check again

  7. B_Dark
    Member
    Posted 8 months ago #

    so, the correct settings is...

    main multisite

    Upload Path: wp-content/uploads
    Blog Upload Space: empty
    Upload Url Path: empty
    Fileupload Url: http://maindomain.com/wp-content/uploads

    and all the subsite like this
    Upload Path: empty
    Blog Upload Space: empty
    Upload Url Path: empty
    Fileupload Url: empty

    ??!

  8. d_random
    Member
    Posted 7 months ago #

    Set the subsites like you have the main site setup, it should work.

    EXAMPLE:

    Edit the site (Network -> Sites -> Edit -> Settings ) and change the following parameters:

    Upload Path wp-content/uploads
    Fileupload Url http://www.mydomain.com/wp-content/uploads

    P.S. Make sure the chmod is set for 777 on the uploads folder.

Reply

You must log in to post.

About this Topic