WordPress.org

Ready to get started?Download WordPress

Forums

Subdomain Blocking (4 posts)

  1. Propane Tank
    Member
    Posted 2 years ago #

    I don't use just wordpress multisite on my domain, so when I try to load some sub-domains, WordPress wants to try and load it. How to I prevent this? Not all my subdomains do it though. I notice that the ones that do it are a 301 redirect in my .htaccess file.

  2. Check your httpd.conf file. If your named subdomains are listed ABOVE the call for wildcard, they take precedence. If wildcard is on top, it goes first.

  3. Propane Tank
    Member
    Posted 2 years ago #

    I have one problem though. I use Webmin to manage my apache virtual hosts and I've been making their own config under sites-available/enabled. Do I need to convert it all into the httpd.conf or is there a way to do it as it? Also, if I have to move it all into one file, will webmin still work with it in an easy to run manor? Not that it's harder to manage it by command line it's just that it's takes longer.

  4. You may need to do it manually. I use WHM and it lets me tweak the order manually, AND saves it.

    Then again, it also keeps itself in the right order 90% of the time for me... Yeah, check manually.

Topic Closed

This topic has been closed to new replies.

About this Topic