WordPress.org

Ready to get started?Download WordPress

Forums

Subdirectory Install Lost Entire Site (8 posts)

  1. kklivingood
    Member
    Posted 4 months ago #

    I tried following the instructions at http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

    One step might have been wrong - I changed both the WordPress Address and Site Address to take out the name of the subdirectory, which was probably wrong, but it's been a long night!

    Of course I get the error message when I save changes. I do the bit with the index file. There isn't an .htaccess file (yes, I know it's hidden and I checked, but I do have an inquiry in to my host to check about it for another reason). Once all the steps were done - nothing. I tried hitting "back" on my browser and re-saving settings (I thought that worked another time), but no change. I uploaded the entire WordPress directory from right before I did any of this thinking that would fix it and it didn't. I get part of it, but not the full design. You can see it at http://stjohnskasson.org/wp/

    Help?

  2. Keith Driscoll
    Member
    Posted 4 months ago #

    Try following this guide to changing the site URL http://codex.wordpress.org/Changing_The_Site_URL

    Using the update_option will work best. Keep in mind that using the define method will hardcode the site and home URL and the option to update them within the admin panel will become greyed out.

    It appears that all your files are in the /wp/ directory so you will want to define home and and site URL as http://stjohnskasson.org/wp/.

    Hope that helps :)

  3. netcentsii
    Member
    Posted 4 months ago #

    Keith:

    I think I've done the same as KK, I've lost several days trying to figure out what's a configuration issue and what is DNS resolution delays. My issue is confused, in my mind, with a HOME page deletion I inadvertently made:

    The new WORDPRESS site I've built is visible at URL : http://waterfordwisp.com/wwisp/

    But, It is not visible at the intended: http://waterfordwisp.com/
    You just find two folders cgi-bin and wwisp listed there.

    I think I deleted a preloaded HOME page when I screwed up the code and the attempt to create a new homepage didn't restore the prior order. I've even uninstalled and re-installed the THEME, but I think it was a WORDPRESS pre-load that isn't restored by a THEME update.

    OR ...

    That has nothing to do with the actual reason our site isn't visible at URL: http://waterfordwisp.com/

    Did I delete an index.php file or something that would redirect to http://waterfordwisp.com/wwisp/ ?????

    --------------------------
    Also/ Symptoms I can't figure out.....

    In the DASHBOARD there is a folder name INFOCUS which contains General Settings and many other configuration folders. One is labeled "Homepage" I've finally figured this folder out and it seems to work correctly at http://waterfordwisp.com/wwisp/

    I do not have a WordPress Page defined as "Home" - that did originally appear as loaded in the site install. I think I was confused that it was not the HOMEPAGE created by InFocus, and it was deleted. I still don't get that but I'd like to have page defined as Home in the Menu that links to what name is used by the file that InFocus Homepage builds.

    I've spent hours searching through the site's files but can't discern an answer. Help please!
    --------------------------------
    See 3rd pic, The WordPress Dashbaord's General Settings' setting doesn't seem to affect this, as I've tried it either way.

  4. kklivingood
    Member
    Posted 4 months ago #

    Keith - THANK YOU! This worked perfectly. Thank you so much for saving me!

  5. Keith Driscoll
    Member
    Posted 4 months ago #

    @kklivingood Welcome:)

    @netcentsii Hi! If you need further assistance, please copy and paste your original post and create a new ticket. It's the only way we have to track issues :0

    The first question I would ask yourself is why do you need WordPress in it's own directory. Though there may be good reasons for this sometimes, ultimately it creates a layer of complexity that just isn't necessary especially for most beginners. So if you can. I would start over. Delete the DB, all the files and start fresh with this tutorial :)

    https://laughingsquid.us/faq/wordpress/install/

    Or better yet, if Laughing Squid has a 'one click' installer in their control panel, use that.

    Good luck! And please create a new forum post to continue this issue :)

  6. netcentsii
    Member
    Posted 4 months ago #

    Keith:

    Thanks, I guess .... reload the site ... sheesh!

    It's funny as I chose to do that at the advice of one of these forums' suggestions for SECURITY so that your WP site is NOT located in an expected hierarchy where the SCAMMERS/SPAMMERS will be looking for it.

    I'll see if my hoster has some redirection solution that can be employed short of rebuilding the site.

    Thanks for the courtesy of your response, truly!

  7. Keith Driscoll
    Member
    Posted 4 months ago #

    Oh...

    Security through obscurity :) That's not the solution. You could start with insalling a good security plugin though. There are a couple of good ones and I would recommend https://wordpress.org/plugins/better-wp-security/

  8. netcentsii
    Member
    Posted 4 months ago #

    Keith:

    I'm trying to do exactly the same things that KK tried to emulate in the article listed:

    http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory in the section called "Using a pre-existing subdirectory install"

    I've done all these steps listed.

Reply

You must log in to post.

About this Topic

Tags

No tags yet.