WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] SubDirectory Dashboard and site not appearing as it should. (3 posts)

  1. afterdarkx
    Member
    Posted 11 months ago #

    Hello all, I'm new to WordPress and am battling an issue that I haven't seen in this forum yet(Some which are close though but dont provide a solution for my problem). I'm running Windows 2012 utilizing IIS 8.0, I have rewrite enabled and ran through the Multisite setup with subdirectories enabled, the primary network dashboard works and appears fine along with the site, the standard site dashboard which is carried over from the standard wordpress install works fine and so does the site but what I'm having a problem with is that I'm trying to understand why, when I add a new site to the multisite network, the subdirectory site appears to be created along with a dashboard of sorts just without the CSS or the theme. It's resulting in pretty blasé view but gives me the impression it's being created to some capacity. You can see in this link. http://www.mferber.net/jack that it's devoid of CSS or any theme and missing some aspects but if you go to the main site things appear normal and fine http://www.mferber.net

    Any ideas?

    A couple of notes: I run this server myself along with the DNS, there's no godaddy issue here, if you're suggesting to reconfigure or set permissions to the host server I can do this but you have to be specific. Also, for the initial install of wordpress I used WPI which seemed to work like a charm but I'm not sure if it does anything funny in regards to WordPress multisite function, however things appear to be very vanilla. Also, IIS URL Rewrite v2 is installed and enabled as you can see below.

    Here's my

    web.config

    <?xml version="1.0" encoding="UTF-8"?>
    <configuration>
        <system.webServer>
    <rewrite>
        <rules>
            <rule name="Main Rule" stopProcessing="true">
                <match url=".*" />
                <conditions logicalGrouping="MatchAll">
                    <add input="{REQUEST_FILENAME}" matchType="IsFile" negate="true" />
                    <add input="{REQUEST_FILENAME}" matchType="IsDirectory" negate="true" />
                </conditions>
                <action type="Rewrite" url="index.php/{R:0}" />
            </rule>
        </rules>
    </rewrite>
            <directoryBrowse enabled="true" />
            <defaultDocument>
                <files>
                    <add value="index.php" />
                </files>
            </defaultDocument>
        </system.webServer>
    </configuration>
    
    And the <strong>wp-config.php</strong> for multisite config
    /* Multisite */
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', false);
    define('DOMAIN_CURRENT_SITE', 'www.mferber.net');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);

    Thanks for any insight you can provide.

  2. afterdarkx
    Member
    Posted 11 months ago #

    Alright, I've got this mystery solved thanks mostly to these guys and their post... http://wordpress.org/support/topic/multisite-install?replies=4#post-2198998

    The re-write rules weren't correct in short but you can't just take the web-config file they suggest you have to make some minor tweaks so that's why I've posted a revised web.config file specifically for IIS 8.0. The post I mention is using IIS 7.x. This copy should only be used for testing purposes and was developed in the following environment: OS - Windows 2012, WordPress was installed using WPI and using IIS 8.0 - enjoy.

    Note: This web.config enables directory browsing access:IIS 8.0 web.config

  3. afterdarkx
    Member
    Posted 11 months ago #

    This topic has been resolved see above for details.

Reply

You must log in to post.

About this Topic