WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Subdirectories not being created CENTOS 6.3 (7 posts)

  1. 996149
    Member
    Posted 1 year ago #

    This may be OT, but here goes:
    Building a WordPress multisite on our internal network for prototyping and testing before release to the prodcution sites.
    The server is a fresh CentOS 6.3 LAMP stack install - no issues there as far as I can tell. Install of multisite is trouble free until the point that I try to create a new subdirectory site.
    Wordpress creates the database entries, but no files / directories are created in /var/www/html/, results in a 404 when attempting to view the site.
    On advice from another admin I tried changing the owner and group permisions of /var/www/html (apache, root, wordpress) and permissions on .htaccess - no changes.

    So - is this an apache issue, a wordpress issue or something else? Any pointers to possible solutions / howtos appreciated.

  2. WP doesn't make new subdirectories when you install Multisite. They're virtual, except for the uploads folders.

  3. 996149
    Member
    Posted 1 year ago #

    Ah, okay - I really need to check the publication date of the posts I'm reading.
    I'm going through the "Debugging a WordPress Network" page.
    wp-config.php seems good, mod_rewrite is enable and I've checked the database and two test sites exist in wp_blogs, with corresponding tables for options, links, comments, etc and they all appear to have valid data. So I'm thinking I'll start looking at apache and the network setup next.

  4. mistfolk
    Member
    Posted 1 year ago #

    I installed WP multisite on 2008 r2 with iis and php. Everything looks right but I am having the same problem as you do. If you ever find out what the problem is/are can you please post it here. Maybe I can get some idea as to where to look.

  5. 996149
    Member
    Posted 1 year ago #

    Will do mistfolk. I'm on leave next week, so it might February before I get back to this.

  6. The 404 is normally because

    1) The .htaccess is wrong
    2) the httpd.conf is wrong (need to set AllowOverride to All)

    I have no idea what that translates to in Windows :(

  7. 996149
    Member
    Posted 1 year ago #

    Errors found in httpd.conf using 'apachectl configtest' and fixed with nano. Thanks Mika.
    mistfolk: I know there is no direct equivalent of httpd.conf in Windows. I've not got access to any '08 R2 servers, but I'm guessing it's the same as earlier versions - if fire up the MMC and add the ISS snap-in you'll probably be looking at the right place.
    Bitnami (http://bitnami.org/stacks) might also be a solution.

    Resolved for me, Many thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic