WordPress.org

Ready to get started?Download WordPress

Forums

Blog Copier
[resolved] Sub site URL path "/" missing after 3.5.1 update (8 posts)

  1. sasikumar3g
    Member
    Posted 1 year ago #

    First of all thanks for the awesome plugin. I use this plugin to copy my Sub site block in my multi site network. I updated WordPress to 3.5.1 and now this is the problem.

    let's say this is the url for my site :- http://www.example.com
    and my main sub sites is :- http://www.example.com/subsite1

    and I used blog copier to clone this site in to
    eg:-
    http://www.example.com/subsite2
    http://www.example.com/subsite3

    It was working fine until the last version. But now after the update when I do the same thing the "/" is missing after the main url

    for an example if I clone the http://www.example.com/subsite1 to lets say subsite4 the new URL will be like this :- http://www.example.comsubsite1

    I can change the path manually by adding the "/" in-between . but it's also effecting all the media inside. So I need to manually change all media which is almost impossible to do.

    how do I fix this problem ?

    Thank you .

    http://wordpress.org/extend/plugins/blog-copier/

  2. BramNL
    Member
    Posted 1 year ago #

    I can confirm this issue exists. In the database the blog path is missing the leading slash.

  3. Wp Master
    Member
    Posted 1 year ago #

    May we have to change in "blog-copier.php file" I am also face this problem!! Any one know the exact solution for this ??

  4. aatospaja
    Member
    Posted 1 year ago #

    Same issue! Urgent fix needed.

  5. aatospaja
    Member
    Posted 1 year ago #

    The problem is in blog-copier.php line 219:

    $path = trailingslashit($base.$domain);

    Global value $base doesn't return the trailing slash on my wp 3.5.1 multisite. Don't know if this has to do with my setup or if it's general in 3.5.1 but you can fix it. Add the following line above tje line 219 on blog-copier.php: $base = trailingslashit($base);

    so that it looks like
    $base = trailingslashit($base);
    $path = trailingslashit($base.$domain);

    This will make sure that the $base value will have a trailing slash in case it's missing.

  6. Wp Master
    Member
    Posted 1 year ago #

    Thanks aatospaja
    it works!!!

    But one problem is still not solved for subdirectories.

    as my site is hosted on asite.com/multisite

    When I am copy
    asite.com/multisite/site1
    to
    asite.com/multisite/site2

    It shows path /site2/ instead of /multisite/site2/

    Thanks for your hard work..

  7. stempelschneider
    Member
    Posted 1 year ago #

    It is not a good idea, to install wordpress multisite in a subdirectory.
    Always chose the domain root for multisite.

  8. sasikumar3g
    Member
    Posted 1 year ago #

    @ aatospaja

    Thanks a lot. it work for me !!!

    There is also a new version of Blog Copier is available. maybe the author corrected this. haven't check yet.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic