WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Sub site backend pointing to primary site backend (7 posts)

  1. erbrown777
    Member
    Posted 3 years ago #

    I updated a multisite site from 3.05 to 3.1.1

    All of the existing sub-blogs point to the correct dashboard. One blog, however, points to the primary site's backend. If I type the correct folder in the address bar the correct backend does open.

    The offending blog seemed to be made the primary blog by default in the upgrade to 3.1.1. I changed the primary site to the correct site, but this did not fix the problem.

    In the same blog moving widgets around does not show the changes on the blog.

  2. All of the existing sub-blogs point to the correct dashboard. One blog, however, points to the primary site's backend.

    Point FROM where? :)

  3. erbrown777
    Member
    Posted 3 years ago #

    Examples of what I mean:

    On the My Sites dashboard page the link to the backend points to the primary site's backend.

    When I am in the backend of the site in question, Updating a page takes me to the main site's backend once the page refreshes.

  4. As in when you're editing a page or post?

    turn off the plugin on that site for starters.

    Is this *any* page or post? Or just specific ones? Could be a url collision as well.

  5. erbrown777
    Member
    Posted 3 years ago #

    Yes all post and pages. When I click edit on a post or page I am taken to a post/page in the main site.

    I should be taken to http://bu.1two3.co.za/classroom/wp-admin/post.php?post=677&action=edit but am taken to http://bu.1two3.co.za/wp-admin/post.php?post=677&action=edit for example.

    I disabled all the plugins but that did not help.

    The same thing happens when I type in the missing folder(classroom) to edit the correct post and click update.

  6. Tim Moore
    Moderator
    Posted 3 years ago #

    Do you have a page on your main site named "classroom" (or whatever it is in your blog)?

  7. erbrown777
    Member
    Posted 3 years ago #

    Thanks for all the suggestions and help.

    After much investigation the sidebar login plug-in seems to be the offender.
    http://wordpress.org/extend/plugins/sidebar-login/

    When the sidebar login is active on a sub-blog and I log into that sub-blog, instead of the main site, every link to the sub-blog's backend now points to the main site's backend.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.