WordPress.org

Ready to get started?Download WordPress

Forums

sub menu not showing automatically using custom menu (1 post)

  1. Stingraynut
    Member
    Posted 3 years ago #

    I have created a test site purely to check this problem.
    No plugins or templates, just a fresh clean install of WP3.0.1

    I created some pages for the menu then created a page and choose the parent page, to make it a submenu item.

    I refreshed the page and the submenu item was there as you would expect.

    So the default Menu system works.

    THEN: I created a menu, added the page with the submenu, saved the menu.
    Refreshed webpage and no sub menu.

    In case I had done things out of order, I created another new page and choose the same menu item as the parent, saved , refreshed and no sub menu item.

    The only way to make those pages sub menu items is to go to menu's and drag them under the right hand menu items.

    I wanted to use the menu function to choose the order of the main menu, but it seems the moment I create a menu instead of using default, the child pages will not show automatically.

    Is there a fix fir this? or should I go back to using the Page Mash plugin? - which would be a pity.

    I am trying to set up a simple website for someone, they will only have Editor access. There is no custom Menu access for Editors but also it may be too complicated for the person.

    WP has fixed so many things, like Categories and Custom Links in the menu, so brilliant, thanks

    Have I misunderstood something, or got something wrong? Would appreciate any advice,

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.