WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Sub-menu Blocks Parent Menu in iNove? (22 posts)

  1. answerthink
    Member
    Posted 1 year ago #

    Some of my menu items have sub-menus (utilizing the iNove theme). When I hover over a menu item that has a sub-menu, the sub-menu blocks the parent menu (as opposed to appearing below it), but only in Google Chrome. The sub-menu appears perfectly in Internet Explorer and Firefox.

    I've tried to mess around with the stylesheet (namely to add "margin-top: 25px;" to "#menus li ul {" ) but when I do so, while I fix the problem in Chrome, I create a problem in the other browsers.

    I have searched these and other forums for a solution before posting. I found two people who apparently had this same problem (http://wordpress.org/support/topic/submenu-looks-different-on-different-browsers-please-help and http://en.forums.wordpress.com/topic/why-the-sub-menu-blocks-parent-menu-in-inove), but their questions both went unanswered. Does anybody have a potential solution?

    Thanks!

  2. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    That theme appears to be quite outdated -

    http://wordpress.org/themes/inove

    You may want to consider finding another one that is currently being supported and maintained.

  3. answerthink
    Member
    Posted 1 year ago #

    I don't think it's a compatibility issue because it's been like this since my install (three years ago, when I believe it was being supported).

    Despite it being outdated, it's still been very good to me, with the exception of this one issue. In fact, on the website of the poster in the second link above, the issue was resolved, but the answer was never posted. I've emailed just in case they're willing to respond. In the meantime, I was hoping that someone might have a fix for me.

  4. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Assuming it's a CSS issue, yes, someone here might be able to help you, but there's no way to help with CSS without seeing the actual site live.

  5. answerthink
    Member
    Posted 1 year ago #

    Well, I can help with that!

    My site: http://heathoops.com/

  6. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    I don't see that issue in Chrome - but I'm on a Mac...

  7. answerthink
    Member
    Posted 1 year ago #

    That's because I've used the "margin-top" workaround I described above (creating problems in all the other browsers).

    I've changed it back again. You should see the problem in Chrome now (though I'm on a PC). If you haven't lost your patience with me, please look again.

  8. Andrew
    Forum Moderator
    Posted 1 year ago #

    I cannot see an issue in the latest version of Chrome on Windows.
    Which version does the issue occur in?

  9. answerthink
    Member
    Posted 1 year ago #

    Thank you both for your responses.

    I am very sorry to confuse you both. I was running the "margin-top" work-around because the issues it creates with the other browsers isn't as bad as the issue I was having with Chrome without it. I apologize for not stating that outright.

    I've changed it back. You should both see the issue now.

    My Chrome version: 26.0.1410.64 m.

  10. Andrew
    Forum Moderator
    Posted 1 year ago #

    Can you use the "top" work-around?
    The submenu is probably already positioned absolute so you should be able to just add that value.

    Do the equivalent of what you did with "margin-top" but just use "top".

  11. answerthink
    Member
    Posted 1 year ago #

    Nope. Switching to "top" does not fix Chrome (or cause an issue in the other browsers). The position, by the way, is absolute.

    I currently have it set as "top:28px;..."

  12. Andrew
    Forum Moderator
    Posted 1 year ago #

    Clear your browser's cache to see whether you still have an issue.
    Your menu is not straight forward. It is styled in JavaScript [screenshot] so your styles are being overridden; yet I don't see an issue with your menu.

  13. answerthink
    Member
    Posted 1 year ago #

    Oops. Cleared the cache. Seems to be working in Chrome, IE, and Firefox.

    My apologies for what appears to have been a simple fix, but I appreciate your help.

    Thanks!

  14. answerthink
    Member
    Posted 1 year ago #

    Shoot. I know I marked this as resolved, but I just noticed that it isn't resolved. The problem does not exist when logged out. It only appears when logged in (and not only when logged in as the admin but when logged in as anybody). The problem was previously resolving itself because, of course, by clearing my cache it was forcing a logout.

    I am not sure if I will need to open up a new forum for this since I erroneously marked it resolved...

  15. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Fixed it for you... Sounds like that may be due to the logged-in admin bar across the top of the screen? Try using a browser tool to see what's going on with the CSS.

  16. answerthink
    Member
    Posted 1 year ago #

    Thanks WPyogi.

    I believe you are correct. Even the "margin-top" solution doesn't work. It fixes the issue when logged in, but causes a problem when logged out. Also, the problem is not exclusive to Chrome. It occurs in Firefox as well (which I hadn't noticed before because I was never logged in on Firefox).

    However, as basic as your suggestion sounds, I, as ignorant as I am, don't really know how to analyze my CSS via a browser tool. I can play around with the stylesheet, but that's really the extent of my capabilities.

    I would love to get an answer, but if I am trying your patience, let me know and I'll stop...

    (Note: I am currently still running the "margin-top" solution because that's the only palatable option to me, but I can change it back if you need).

  17. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    See if adding some padding to the body does anything - it's hard to work on this cause I'm not logged in (obviously):

    body {
       padding-top: 20px;
    }

    That will likely make space on your logged out page too, but let's see what it does for the logged in.

    I'm also about to take a break for a bit, but I'll check back on this... and it's not that you're trying my patience at all :). Just gotta do a few other things/make dinner, etc.

  18. answerthink
    Member
    Posted 1 year ago #

    No problem. I'll keep playing around with it.

    If you (or anybody else) want, I've created a fake username and password for you to be able to log in:

    Site: http://heathoops.com
    Username: [yikes - please don't post access info on a public forum]
    Password: [and change those asap]

  19. answerthink
    Member
    Posted 1 year ago #

    i'm confused. why not? it's a dummy user account registered with a dummy email address which has no admin access. i created and posted it solely so that people could log in to the site to see the issue.

    To be more clear, the issue I am encountering is not only when I log in as an admin but as any random subscriber.

  20. Andrew
    Forum Moderator
    Posted 1 year ago #

    it's a dummy user account registered with a dummy email address which has no admin access

    Regardless, you'll get hacked.

  21. answerthink
    Member
    Posted 1 year ago #

    No problem. I deleted it.

  22. answerthink
    Member
    Posted 1 year ago #

    For all others who have this problem in the future, here's the fix: http://wordpress.org/support/topic/inove-menu-item-offset-with-wordpress-admin-bar-fix

Topic Closed

This topic has been closed to new replies.

About this Topic