WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] sub-directory site links don't work (5 posts)

  1. RockChickEnt
    Member
    Posted 3 years ago #

    I finally got multisite working, and just set up another site however the link is broken? Using sub-directories.

    http://www.mymusicmerch.com is the main site and the first additional site is http://www.mymusicmerch.com/gowan

    No clue what I'm missing here.. can anyone assist? I need this site set up like yesterday :(

  2. And your permalinks on the main site aren;t working either.

    http://mymusicmerch.com/blog/2011/02/10/hello-world/

    so, htaccess. Check it. make sure it;s being read.

  3. RockChickEnt
    Member
    Posted 3 years ago #

    Thanks Andrea.. I was finally realizing that it's an htaccess issue. BUT.. I'm a total rookie with that stuff. So no clue what to do?

    Also.. I just looked at the blogs.dir folder and it's empty..

    # BEGIN WordPress
    <RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    # END WordPress

  4. RockChickEnt
    Member
    Posted 3 years ago #

    permalinks are only working in "default" :(

  5. talk to your webhost then.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags