WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Styling broke in wp-admin in all the sites on my host (5 posts)

  1. Paul Phillips
    Member
    Posted 2 years ago #

    This is most bizarre!

    The wp-admin interface has decided to break on all the site on my host. The frontend is being served fine but the backend seems to have lost the css?

    I could understand if one had got corrupted or something but I can't think what could go wrong to mean any site serving a wp-admin UI causes an error.

    Anyone got any ideas?

  2. Jackson
    Member
    Posted 2 years ago #

    I would use Firebug to inspect the network resources being requested.

    You'd be looking for something like...

    http://domain.com/wp-admin/load-styles.php?c=1&dir=ltr&load=global,wp-admin,ms&ver=bdb0ec292ad0b1a07f3b44410fe99090

    Find that and open in a new window, see if it's returning the proper CSS, if not - I'd bet that's the source of your problem.

  3. eryanv
    Member
    Posted 2 years ago #

    You may want to check to see if it's looking alright in another web browser. Also, was anything on your site or how you're accessing it updated recently?

  4. Paul Phillips
    Member
    Posted 2 years ago #

    Cheers for the pointers.

    That is indeed the cause of the problem although I'm still a little baffled at why it's suddenly changed.

    I've just edited load-style.php and added the error reporting;

    error_reporting( E_ALL | E_STRICT );

    Hasn't really given me anymore clues though.

    All my sites look like this;
    http://blog.ftwr.co.uk/archives/2009/09/29/missing-dashboard-css-and-the-perils-of-smart-quotes/

    In any web browser! Grrr!

  5. Paul Phillips
    Member
    Posted 2 years ago #

    Fixed it, I added

    define('CONCATENATE_SCRIPTS', false);

    Before the require_once in wp-config.php.

    Still seems very odd though and I've had to do this for every site on my host.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.