WordPress.org

Ready to get started?Download WordPress

Forums

iContact Widget
Styling attributes being ignored (4 posts)

  1. Ann McG
    Member
    Posted 1 year ago #

    I am trying to add the iContact form to a WooCommerce based site. The form adds in ok, but the sizing and other style attributes are being ignored or overridden.

    I was able to add the form code to the header within a DIV tag, but the form itself is still wonky (added padding, etc)

    When I add it in a page with the widget shortcode, it spreads out across the whole page:

    (see http://bambooleaftea.net/about-bamboo-leaf-tea/ at the bottom of the page)

    ANY help at all is appreciated!

    http://wordpress.org/extend/plugins/icontact-widget/

  2. romtek
    Member
    Posted 1 year ago #

    That's because style.css for your theme contains this rule on line 765:

    table {
    border-collapse: separate;
    margin-bottom: 1.5em;
    width: 100%;
    }

    You need to provide a more specific rule for the table in your form to override that setting.

    The developer of this plugin could generate specific CSS rules to control the appearance of the form better.

  3. MCnewBiz
    Member
    Posted 1 year ago #

    Romtek, can you be more specific? What rule do you suggested and where does it get placed? I'm using the widget in the sidebar ...

    Thanks!

  4. ewiart
    Member
    Posted 1 year ago #

    I am having exactly the same problem. except that I am using a different theme. Can you help to fix the problem? thank you

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic