WordPress.org

Ready to get started?Download WordPress

Forums

Style Switcher Problem (7 posts)

  1. Beel
    Member
    Posted 10 years ago #

    Just replace it, shouldn't matter. If it isn't working give us a link to your blog and we will go from there.

  2. Joe
    Member
    Posted 10 years ago #

    It's one of my hosting client's blogs, so I'm not sure if they would want me publishing the link(not sure why they would mind either, but better safe...)
    I have already tried just replacing the line. All styles in the wp-style folder are listed on the main index page with links "http://www.site.com/blog/index.php?wpstyle=blue", etc. However, clicking on any of the links just results in wp-default being loaded.
    I've also tried installing the hack the "old way", using my-hacks.php as with 1.0, but I had the same problem. That's why I thought that maybe the style sheet is being called differently in 1.2.

  3. Beel
    Member
    Posted 10 years ago #

    cookies turned on?

  4. Joe
    Member
    Posted 10 years ago #

    Yes, cookies are on. In fact, the example switcher on Alex's site works fine.
    I had the switcher working fine with 1.0 on the same server and no PHP settings have been changed.

  5. thunderbyrd
    Member
    Posted 10 years ago #

    Just for the record, I had exactly the same problem and was never able to get it to work. I just gave up.

  6. Beel
    Member
    Posted 10 years ago #

    Next question - where is the index page in relation to the rest of the WP files?

  7. Beel
    Member
    Posted 10 years ago #

    Glad you got it, that was going to be my next suggestion. I had tested converting the style-switcher to handle the index page in the root directory and when I switched it back I had to delete the cookie in order for it to work again.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.