WordPress.org

Ready to get started?Download WordPress

Forums

Style not loading on Firefox (9 posts)

  1. zakis
    Member
    Posted 9 years ago #

    http://www.argyropoulos.net/index.php
    When viewing my default installation with Firefox I do not get the wp-layout.css layout . Instead the index page shows a text-only version.
    IE6 loads the page ok.
    Any suggestions?
    Zakis

  2. moisie
    Member
    Posted 9 years ago #

    Try putting " on either side of the url for the stylesheet. The odd thing is if I use one of the stylesheet editors for firefox the stylesheet then loads, they obviously read them differently.
    @import url("http://www.argyropoulos.net/wp-layout.css");

  3. TechGnome
    Moderator
    Posted 9 years ago #

    Do you have the Web Devloper extention installed? If so, check to make sure you haven't accidently set it to disable all styles. (Ctrl+Shift+D) will toggle it.
    Tg

  4. TechGnome
    Moderator
    Posted 9 years ago #

    Okaaay... never mind that..... I see now that it doesn't work for me either.....
    Just for fun, change your style link to this:
    <link rel="stylesheet" href="<?php echo get_settings('siteurl'); ?>/wp-layout.css" type="text/css" media="screen" />
    Tg

  5. michaelward82
    Member
    Posted 9 years ago #

    Your problem is the content-type that your server is sending with your .css files. It should be sending text/css but is actually sending text/plain.
    You can see this by entering the address of one of your stylesheets at http://www.rexswain.com/httpview.html
    Because your server is running the Apache software, simply placing the following code in the .htaccess file in the root of your site should solve your problems:
    AddType text/css .css

  6. stanoman
    Member
    Posted 9 years ago #

    I wanted to add another thanks to michaelward82 for this fix. I was doubtful that adding the AddType Apache directive would actually fix the problem; but alas - it did.

  7. draegonlady
    Member
    Posted 9 years ago #

    I have to join crowd and add my thanks for this fix. Like Stanoman I didn't think adding the directive was the answer, but since I'd tried everything else with no luck, I tried it. Instant fix. :) Thanks so much!

  8. davlux
    Member
    Posted 8 years ago #

    Talk about the magic bullet. I'm a less than competent coder (sorry to add to the mess...) and have been working for several days trying to fix this same problem. I knew it had something to do with the content-type misdirection from my multiple red flags in my Firefox's JavaScript Console. Thanks michealward82 for providing the answer in 20 characters or less!

  9. cogdog
    Member
    Posted 7 years ago #

    I'm having similar issues on http://virtualworlds.nmc.org -- users of Firefox are occaisionnaly seeing unstyled content- a Shift-Reload clears it, but people think the site is broken.

    The magic bullet did not work as the tool (a great one to have, so thanks) indicates our Apache server is sending it as text/css.

    Also, just cleaned up 4 CSS validation errors (now validates). Also noticed that my CSS file had Mac encoded line returns, changed to unix (might that be an issue??)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.