WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Stuff getting wiped out for no reason. (3 posts)

  1. backagain
    Member
    Posted 1 year ago #

    I'm using JotForm forms on several pages of a site. In order to embed the JotForm script, you have to be in HTML view--fine. But if you then go back and just open the page for editing when in "Visual" mode, the code snippet gets wiped out and has to be re-inserted.

    Anybody else having this issue?

  2. wpismypuppet
    Member
    Posted 1 year ago #

    Yes... It's a common problem with the way the default visual editor tries to "format" the code. The only solution is to stay in HTML mode and never go back!!! Or use a different visual editor other than the default!

    What we do is use Gravity Forms. It's $40 for one site, more money for more sites. But it's basically JotForm built into WordPress. So easy to use, only one login. I know you probably don't want to pay money for anything... but we used JotForm for a long time until we found this plugin.

    If you are set on keeping JotForm, then you can try to use Ultimate TinyMCE or even TinyMCE Advanced. Either of these two will alter the visual editor and improve performance switching between HTML and Visual editors. Let me know if this helps...

  3. broekmancomm
    Member
    Posted 1 year ago #

    I had same problem OVER AND OVER AGAIN.

    Installing the WordPress Jotform Plug-in works PERFECTLY.
    http://wordpress.org/extend/plugins/jotform-integration/

    1. Installed the plug-in
    2. Activated.
    3. Went to settings and JotForm Integration to enable "caching" of forms
    4. Went to my respective pages & posts where I had the embed code....
    and replaced with this SHORT CODE
    [jotform id=XXXXXXXXXXXXXX]

    Replace the XXXXXXXXXXXXXX with your form's ID!!!!

    WORKED LIKE A CHARM!!!!

Topic Closed

This topic has been closed to new replies.

About this Topic