WordPress.org

Ready to get started?Download WordPress

Forums

Studiopress Lifestyle Theme Options Not Working After 3.1 Update!! (21 posts)

  1. TwoDayGetaway
    Member
    Posted 3 years ago #

    I have the Studiopress Lifestyle Theme and when I updated to WP 3.1 I lost the ability to make any changes in the theme options.

    I have already tried:

    Turning off all the Plugins, renaming the plugin folder, and uninstalling all the plugins.

    Installing the default theme and reinstalling the lifestyle theme

    Installing another Studiopress theme, it has the same problem.

    Deleting cache

    I am running out of options here.... It is obviously a problem with the update, but I don't know what else to try. Please help

    The site is http://www.TwoDayGetaway.com

  2. brettbrandology
    Member
    Posted 3 years ago #

    I have the same! It must be that, I thought it might be permissions, but it cannot be anything other then the upgrade as my sites that have not been updated to version 3.1 are fine and I can save the theme options. Do you think its worth asking the guys at studiopress?

  3. TwoDayGetaway
    Member
    Posted 3 years ago #

    I would, but I don't have forum access...

  4. Samuel
    Member
    Posted 3 years ago #

    I've got the same problem too. I bought the site few months back and it was working fine until the update to WP 3.1.
    Did any of you guys find a solution?
    Thanks

  5. TwoDayGetaway
    Member
    Posted 3 years ago #

    Nope, I switched to a different theme since then because I couldn't get it right...

  6. Rebecca Diamond
    Member
    Posted 3 years ago #

    The answer can be found in the support forum here: http://www.studiopress.com/support/showpost.php?p=275852&postcount=22

    As a reminder, everyone who has a purchased copy of Lifestyle Classic will see when they login that they also have Genesis access - each Classic user was grandfathered in to the new version.

  7. Samuel
    Member
    Posted 3 years ago #

    That is like impossible for me. I bought the website and it came with the theme installed. I don't have access to any other details other than the theme. :(

  8. Rebecca Diamond
    Member
    Posted 3 years ago #

    We have seen that on occasion, and I do apologize! I know I typically urge developers to encourage their clients to purchase the theme to have access to ongoing support.
    Your developer may have purchased the theme as a one-off for your project, so it's worth contacting them to see if you can get support forum access that way.
    If not, you may wish to purchase your own copy of the theme, which will provide not only a fix for your current solution, but will also grant access to ongoing updates via the Genesis framework.

  9. Samuel
    Member
    Posted 3 years ago #

    Ok will contact seller and take it from there.
    Thanks Rebecca you been great!

  10. mark7694
    Member
    Posted 3 years ago #

    I am having the same problem. I just tried the step listed above in the studiopress forum and this is the result I got:

    Parse error: syntax error, unexpected T_VARIABLE in /home1/mtwoxweb/public_html/dmngoodstaging/ctr/wp-content/themes/career/tools/theme-options.php on line 11

  11. Rebecca Diamond
    Member
    Posted 3 years ago #

    Mark, go ahead and post that on the support forum if you would, in that thread - we'll help you troubleshoot it there. We try to consolidate support there as much as possible :-)

  12. mark7694
    Member
    Posted 3 years ago #

    Thanks for the quick response, Rebecca. I actually got it to work. I had changed the name of the folder and didn't realize that's what it was pointing to. Found the answer here: http://www.studiopress.com/support/showthread.php?t=53275

  13. Rebecca Diamond
    Member
    Posted 3 years ago #

    I'm glad it's working for you now! :-)

  14. nrq30
    Member
    Posted 3 years ago #

    Hi guys! I'm pretty desperate to solve this problem, but I don't have access to the Studiopress suport forum.

    Could it be possible for someone to PLEASE post the solution here?

    Thanks!

  15. Rebecca Diamond
    Member
    Posted 3 years ago #

    You can email me at rebecca at copyblogger.com with the email address used to make the purchase - I can help you sort our your forum access that way :-)

  16. doriggidy
    Member
    Posted 3 years ago #

    Here's an idea...
    Open /wp-content/themes/YOURTHEME/includes/theme-options.php,

    change:

    $settings = ‘mods_’.get_current_theme();

    to:

    $settings = ‘theme_mods_’.get_current_theme();

    Then go to WP Dashboard -> Appearance ->Your Theme Options, click “Save Settings”

    ...courtesy of google and http://www.webcoz.com/how-to-fix-theme-junkie-themes-theme-options-compatible-issue-with-wordpress-3-1/

  17. Floridan
    Member
    Posted 3 years ago #

    Thanks for the fix doriggidy. The theme-options.php file can also be found inside your theme's 'Tool' folder.

  18. doriggidy
    Member
    Posted 3 years ago #

    yep...np

  19. brettbrandology
    Member
    Posted 3 years ago #

    I tried the above fix but found it did not work.

  20. digitalclubb
    Member
    Posted 2 years ago #

    Two things are needed for the fix, these are the following:

    1. Check theme name in stylesheet.css, make sure the folder that houses the theme files has this name. (After renaming you will have to 'reactivate' the theme in WordPress)
    2. As above, go into tools folder and edit theme-options.php, search for $settings = ‘mods_’.get_current_theme(); and change to $settings = ‘theme_mods_’.get_current_theme();

    Good luck :)

  21. mrmbdctg
    Member
    Posted 2 years ago #

    I don't know whether you have solved the issue or not but the solution is so simple and it's simply described here in the previous posts..

    change:

    $settings = ‘mods_’.get_current_theme();

    to:

    $settings = ‘theme_mods_’.get_current_theme();

    But the main things to remember is that php language support single only ' not the sign written in the answer.
    I think now you got the answer.

Topic Closed

This topic has been closed to new replies.

About this Topic