WordPress.org

Ready to get started?Download WordPress

Forums

eShop
[resolved] Stuck on Processing (19 posts)

  1. xelect
    Member
    Posted 1 year ago #

    I've read several times no support for Authorize but what am I supposed to do? This was my last restore, which was to start a discussion about this.

    I upgraded to the lasted version of eshop and now my transactions are stuck on processing. If I could get some help I would greatly appreciate it.

    Things I have done & tried
    1.) Disable all plugins
    2.) Switched to 2011 theme
    3.) Checked all my setting from Authorize & eshop settings. (Everything is perfect)

    Any help would be great. Thanks

    http://wordpress.org/extend/plugins/eshop/

  2. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    Does a Cash or Bank sale work?

  3. xelect
    Member
    Posted 1 year ago #

    Cash or Bank Sale? I don't really know how to answer this question. If I received cash I would not use the site. So I guess... no? I know that doesnt help much. I only used credit card transactions on the site.

    I have made in image to clearly explain the situation.
    http://i.imgur.com/GfMw8.jpg?1

    As you can see under the title Transaction ID the status will remain in "Processing" mode for transactions and it is stuck on "Processing".

    Can you please help me

    Let me know if a "donation" is required ;)

  4. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    Try setting up the Cash gateway and using it to make a test purchase.

  5. xelect
    Member
    Posted 1 year ago #

    Well it was a little more complicated then that.

    I got the feeling that no one wanted to be involved when i was willing to make a "donation" so i quickly hired a programmer.

    Not only did i pay him but I also asked him if he was ok if i shared the code. and he said yes. so for all those ppl that were having the same trouble as me. Change the red coding to the blue.

    Here is the link:
    https://gist.github.com/4217707

    Good Luck

  6. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    I got the feeling that no one wanted to be involved when i was willing to make a "donation"

    Pardon? I responded in less than 1 hour!

    Change the red coding to the blue.

    If you do, we will no longer support eShop on your site.

  7. xelect
    Member
    Posted 1 year ago #

    huh? I dont know why ur being so upset? I was just trying to help. I didn't mean to offened anyone. So what should I do change it back? How am I going to resolve my issue?

  8. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    I dont know why ur being so upset?

    You implied that you did not get any support when, in fact, the response speed was bordering on blistering. Did you even try the suggestion I gave above?

    So what should I do change it back?

    Re-upload a fresh, unpacked, copy of eShop to wp-content/plugins using FTP.

    How am I going to resolve my issue?

    By first determining where the issue actually is - which is what I was trying to do.

  9. xelect
    Member
    Posted 1 year ago #

    http://i.imgur.com/Tj9O2.jpg

    I uninstalled eshop and re installed it (as you wanted) and as you can see with the picture the problem still exists. I tested it 4 times.

    Kindly let me know what would you like me to do next?

    Thanks for the support

  10. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    Have you tried carrying out a test Cash or Bank purchase yet?

  11. elfin
    Moderator
    Plugin Author

    Posted 1 year ago #

    After you have confirmed it works on cash or bank as esmi suggests, try adding this to your themes function file:

    add_filter('myeshopxrelay', 'eshop_authorizenet_xrelay');
    
    function myeshopxrelay($val){
       return 'use';
    }

    That should fix the authorize.net issue for you without having to change any code within the plugin. I haven't tested that, but I think I have the correct syntax. If that does work please let me know and we'll add it to the wiki.

  12. xelect
    Member
    Posted 1 year ago #

    The cash option worked.

    When I placed

    add_filter('myeshopxrelay', 'eshop_authorizenet_xrelay');
    
    function myeshopxrelay($val){
       return 'use';
    }

    This is what I got.

    add_filter('myeshopxrelay', 'eshop_authorizenet_xrelay'); function myeshopxrelay($val){ return 'use'; }
    Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/content/89/8616089/html/xelectco/wp-content/themes/subtle-wp/functions.php:76) in /home/content/89/8616089/html/myweb/wp-content/plugins/eshop/eshop.php on line 46
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/content/89/8616089/html/myweb/wp-content/themes/subtle-wp/functions.php:76) in /home/content/89/8616089/html/myweb/wp-includes/pluggable.php on line 881
  13. elfin
    Moderator
    Plugin Author

    Posted 1 year ago #

    where exactly did you place it?

  14. xelect
    Member
    Posted 1 year ago #

    (functions.php)

  15. xelect
    Member
    Posted 1 year ago #

    the themes' function.php template

  16. elfin
    Moderator
    Plugin Author

    Posted 1 year ago #

    the first thing in that file should <?php try adding it after that, and ensure that there is no spaces before that opening php tag.

  17. xelect
    Member
    Posted 1 year ago #

    Its still stuck on processing.

    http://i.imgur.com/32Ha0.jpg

    Now there are a total of 5 transactions not working.

    Not only, that after completing the transaction it does not throw you back to the original website.

    Here is the placement if you wanted to see where I put the code.
    http://i.imgur.com/UVVNo.jpg

  18. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    So you added it to the top of your theme's functions.php file? Is there anything else in that file?

  19. elfin
    Moderator
    Plugin Author

    Posted 1 year ago #

    Not only, that after completing the transaction it does not throw you back to the original website.

    That is an authorize.net issue, you don't actually get sent back to your site from them, at least not correctly.

    Have you tested with all other plugins deactivated?

    Really you should test in twenty ten or twenty eleven themes as well - but you will need to add the code to their functions files as well.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic