WordPress.org

Ready to get started?Download WordPress

Forums

Strongly Felt Criticism About "Are you sure you want to do this? Please try agai (3 posts)

  1. WCityMike
    Member
    Posted 5 years ago #

    I have been attempting to get a plugin working on WordPress.

    The sole error message from WordPress has been: "Are you sure you want to do this? Please try again." The latter three words are a circular link back to the page.

    Checking via Google, this appears to be an error message generated by Google and not the plugin.

    I cannot strongly criticize this error message enough. It scores nearly as high on the top 10 list of useless error messages as "Keyboard not found, press any key to continue."

    To be more precise and less hyperbolic, the message tells the user absolutely nothing whatsoever about what is going on. It is not a true confirmation dialogue because there is not an opportunity to answer the question being posed. The link in this particular case merely goes to the same page; I am not sure if this happens in every other case.

    Googling revealed that this may have something to do with something called a "nonce" which superceded the strategy of checking the HTTP referrer. This, to be honest, is above my head a bit. But a dialogue attempting to explain some of it ... or, frankly, saying ANYTHING that actually related to whatever was going on ... would have been mountains upon mountains more useful than this piece of crud.

    I would very strongly advocate that this error message be changed to be a more intelligent description of whatever is generating the error message, along with a suggestion of what avenue the user might pursue in order to fix it.

    As it stands, I have absolutely no idea where the error lies and no idea what to investigate to fix it, and that is because such initial guidance is usually provided by an error message. This message fails at the basic purpose of what an error message should perform.

  2. WCityMike
    Member
    Posted 5 years ago #

    (I have opened an actual support thread for the plugin in question, so I've not neglected actually trying to fix the problem. But I thought the utter cluelessness of this error message needed to be addressed as a bonafide honest-to-God BUG that needed to be squashed.)

  3. mfocazio
    Member
    Posted 5 years ago #

    I think that we solved this issue within the server php.ini file.

    I was trying to send FLV files from my mac to the WP media area, and got the same errors.

    I set the upload limits to 64M in php.ini to no avail, but I then noticed that there's a setting for files originating on a mac - it's located in the Fopen wrappers section of the php.ini file,

    "autodetect line endings = off" and remove the comment (semicolon) in front of it.

    You'll need to restart the server, but after that it worked (for us at least)

Topic Closed

This topic has been closed to new replies.

About this Topic