WordPress.org

Ready to get started?Download WordPress

Forums

Polylang
[resolved] String translation won't work (5 posts)

  1. alexfaille
    Member
    Posted 1 year ago #

    Hi,

    Great plugin, really easy to use for pages and menu. I'm having trouble with the string translation part.

    I wan't to change elements such as my slider text, a «call us» text and a couple of things from my static frontpage. The strings are there, for example : c2_slide_default_info_txt_1. I can write the translation, but the changes doesn't appear on my website when I change from a language to another.

    I'm using the U-Design theme that I bought from Themeforest if that can help. Thanks for the help!

    http://wordpress.org/extend/plugins/polylang/

  2. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    It seems that your theme is attempting to support Polylang and / or WPML but something goes wrong.

    It is possible that the theme author expects that you use the option "add the language code to all urls" in Polylang settings. Did you test this?

    Have you a file called wpml-config.xml in your theme directory?

  3. alexfaille
    Member
    Posted 1 year ago #

    Yes I do have this file

  4. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    I updated my post while you was answering. Could you try to add the language code to all urls in Polylang settings ?

  5. alexfaille
    Member
    Posted 1 year ago #

    Simple as that. I feel like an idiot but I'm glad it works. Thanks a lot!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic