WordPress.org

Ready to get started?Download WordPress

Forums

BackWPup Free - WordPress Backup Plugin
STRICT NOTICE: is_a(): Deprecated. Please use the instanceof operator (4 posts)

  1. mathewmackenzie
    Member
    Posted 1 year ago #

    I've suddenly started getting this message in my log files:

    STRICT NOTICE: is_a(): Deprecated. Please use the instance of operator

    This on different websites with different hosts. All using latest version of plugin and wordpress.

    On one installation I also got this error and the backup failed (have tried several times):

    ERROR: PclZip archive add error: PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature

    Everything worked fine a few days ago.

    Any ideas?

    http://wordpress.org/extend/plugins/backwpup/

  2. boah123
    Member
    Posted 1 year ago #

    I also have this error:

    [27-mei-2013 14:02:13] Database dump done!
    [27-mei-2013 14:02:13] STRICT NOTICE: is_a(): Deprecated. Please use the instanceof operator
    [27-mei-2013 14:02:13] STRICT NOTICE: is_a(): Deprecated. Please use the instanceof operator
    [27-mei-2013 14:02:16] 1. Trying to make a list of folders to back up …
    [27-mei-2013 14:02:52] 689 folders to back up.
    [27-mei-2013 14:02:52] STRICT NOTICE: is_a(): Deprecated. Please use the instanceof operator
    [27-mei-2013 14:02:52] STRICT NOTICE: is_a(): Deprecated. Please use the instanceof operator
    [27-mei-2013 14:02:55] 1. Trying to create backup archive …
    [27-mei-2013 14:02:56] Compression method is PclZip
    [27-mei-2013 14:09:25] WARNING: Job restart due to inactivity for more than 5 minutes.

    I guess it still has to do with this issue

  3. wdwgolfer
    Member
    Posted 1 year ago #

    Just an FYI, that the:

    STRICT NOTICE: is_a(): Deprecated. Please use the instance of operator

    is likely because you are running PHP 5.2. is_a() was "undeprecated" in PHP 5.3.

    I just updated my site today from 5.2 to 5.3 and that notice went away.

    On the other ERROR related to Zip, try to change the compression method to TAR and also be sure that you have enough disk space on the target drive.

  4. kreativhuhn
    Member
    Posted 2 months ago #

    Same error here. PHP version is 5.2.17
    But for sorry, it's not my webserver and I can't upgrade php.

    Is there any workaround?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.