WordPress.org

Ready to get started?Download WordPress

Forums

Strange URL constuction with multisite (48 posts)

  1. ND
    Member
    Posted 4 years ago #

    When I create a site (under a multisite setup), the path to the site getting constructed incorrectly. (NOTE: I have 3b2 set up to create sites as sub-domains.)

    I'm getting a path that looks like this:

    http://test.www.domain.comdatabasename/

    The .com is followed immediately by what appears to be the name of the mysql database for the WP installation. Is that just a strange coincidence? I've had this result twice. Weird.

    Earlier, I came across a help page (possibly in the codex?) that said that the www. should be removed from one of the places in setup where the base URLs are entered. I assume that accounts for the www in the above URL following the subdomain. But can't locate that help page again, and for some reason I also can't locate the setup page where that info is specified (does it get moved once MULTISITE is enabled?)

    Thanks!

  2. mquinnsweeney1
    Member
    Posted 4 years ago #

    I am having the same issue with the final release of 3.0 but I am not using subdomains, so my secondary sites are http://domain.comdomain_com_2test, running together the main url with the name of my database (domain_com_2) and the "test" is what I told it to call the blog, so it should just be http://domain.com/test

    Thanks

  3. Indeedle
    Member
    Posted 4 years ago #

    I'm getting weird paths showing up when I create my sites too. Eg: site.host.com will be created with an address of site.host.comsite_name

    Manually editing the blog options and removing the generated path got the blog working for me.

  4. Anna
    Member
    Posted 4 years ago #

    Had this problem as well and I even posted about it on trac.

    The devs couldn't reproduce it although I could reproduce it as many times as I wanted with my setup (whether I had "www" or not). I thought it was only my installation but now that you guys are posting about it, I guess I was wrong.

    The only "cure" I used was to completely reinstall everything from scratch.

  5. Kalsongriddaren
    Member
    Posted 4 years ago #

    I had the same problem when installing MU on 3.0, but didn't think it would mess up things.. i was wrong, only getting 500 internal error when going to sub-blogs. (Wildcard is active on the server)
    So i have gone trough the database now thinking it should be some thing that's happened there. And found some odd things(think there odd at least..).
    In the wp-options - _transient_dirsize_cache line the url is messed up when pointing to the "blogs.dir". It's saying:
    a:1:{s:88:"/customers/domain.se/domain.se/httpd.www/wp-content/blogs.dir/1/files/";a:1:{s:4:"size";b:0;}}

    I don't know if it's suppose to be like that but in my eyes it looks wrong.. Any one that's better then me that have any thoughts?

    EDIT: Can also add that it seem to be the only place in the database that points to blogs.dir

  6. The only "cure" I used was to completely reinstall everything from scratch.

    then if it was truly a big that wouldn't work. ;) Likely a typo, a forgotten step, a stray character...

    So i have gone trough the database now thinking it should be some thing that's happened there. And found some odd things(think there odd at least..).
    In the wp-options - _transient_dirsize_cache line the url is messed up when pointing to the "blogs.dir". It's saying:
    a:1:{s:88:"/customers/domain.se/domain.se/httpd.www/wp-content/blogs.dir/1/files/";a:1:{s:4:"size";b:0;}}

    I don't know if it's suppose to be like that but in my eyes it looks wrong.. Any one that's better then me that have any thoughts?

    It's only caching the location of your uploads. Yes, it's supposed to look that way.

  7. SidianMSJones
    Member
    Posted 4 years ago #

    I also have this problem and just posted about it.

    For instance my site is MyMythos.org and when I create a Site titled Sidian it produces this URL for it: mymythos_orgsidian/
    which only gives my ISP's error page "Could not be found"

    What do I need to do here? This is halting site production until I can fix it :(

  8. You've got a typo somewhere.

  9. SidianMSJones
    Member
    Posted 4 years ago #

    What sort of typo? In the htaccess? Or in my WP settings somewhere?

  10. SidianMSJones
    Member
    Posted 4 years ago #

    Ok so I've gotten some more info on this but haven't quite solved it yet.

    When I go to Edit the new sub-site titled Sidian, I can see a lot of options including things about it's URL. For instance:

    Siteurl: http://www.mymythos.orgmymythos_orgsidian/ (messed up)

    Home: http://www.mymythos.orgmymythos_orgsidian/ (messed up)

    Fileuploadurl: http://www.mymythos.orgmymythos_orgsidian/files (messed up)

    So my question is, how do I change the original parameters that are causing my new sub-sites to spawn with these screwy default settings?

    I know I can change them on a sub-site by sub-site basis, but obviously the efficient thing to do is nip all that in the bud so that the sites simply aren't create in this manner.

  11. SidianMSJones
    Member
    Posted 4 years ago #

    Would a reinstall do anything?

  12. SidianMSJones
    Member
    Posted 4 years ago #

    I will paypal $10 to whoever can show me how to change the settings for sub-site spawning.

  13. Would a reinstall do anything?

    See previous posts in this thread where a reinstall fixed it.

  14. SidianMSJones
    Member
    Posted 4 years ago #

    Tried reinstall.
    It turned the weird URL'd sub-sites into normal URLs (like mymythos.org/sidian) but visiting them still yielded 'page not found'.

    Also, upon deletion and recreation they were back to the funky URL structure. :(

  15. Nashwan Doaqan
    Member
    Posted 4 years ago #

    I have the same proplem we need help ? please

  16. It turned the weird URL'd sub-sites into normal URLs (like mymythos.org/sidian) but visiting them still yielded 'page not found'.

    Do you have working pretty permalinks off the main blog?
    Did you put the .htaccess file there correctly?

    Subfolder blogs work on the basis of mod_rewrite reading the htaccess file. If the server doesn't have mod_rewrite or it isn't reading the htacess file, it can't find the blog.

  17. SidianMSJones
    Member
    Posted 4 years ago #

    I do have pretty permalinks on the main blog, yes.
    "/%category%/%postname%/"

    Not sure how I would 'put the htaccess file there correctly' though. I didn't think when you changed your permalinks that you needed to do anything with the htaccess.

    Right now I'm unable to see my htaccess in my mymythos.org folder, but I believe that's because it's a hidden file. Could be wrong though.

  18. Not sure how I would 'put the htaccess file there correctly' though.

    Gah, I meant when you set up the network initially, did you put the new rewrite rules in the htaccess file?

    Yeah, it's a hidden file.

    On some systems, mod_rewrite is enabled, pretty permalinks work, but for some reasons it's just not reading the .htaccess file correctly, so it won't serve up the subfolder blogs.

    And normally, yes, if you change permalinks on a single install, it edits the htaccess file for you (if it can) or warns you to put some edits in (if not there).

    See here:
    http://codex.wordpress.org/Permalinks#Fixing_.htaccess_Generation_Issues

  19. SidianMSJones
    Member
    Posted 4 years ago #

    Yes! I remember putting in the new rules, but perhaps I did them wrong. I'll check that out.

    I told Cyberduck to 'show hidden files' though and the htaccess still isn't visible unless I do a file search for it which is strange. Shouldn't it be in the mymythos.org folder?

  20. Yep, shoudl be there.

    If it's not, that'd be the issue.

  21. SidianMSJones
    Member
    Posted 4 years ago #

    Hm, so it is there and this is what it says:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    </IfModule>
    
    # END WordPress
  22. Yep, looks right. What about your wp-config.php file?

  23. SidianMSJones
    Member
    Posted 4 years ago #

    wpconfig...

    <?php
    /** WordPress's config file **/
    /** http://wordpress.org/   **/
    
    // ** MySQL settings ** //
    define('WP_CACHE', true); //Added by WP-Cache Manager
    define('DB_NAME', '*******');     // The name of the database
    define('DB_USER', '******');     // Your MySQL username
    define('DB_PASSWORD', '*******'); // ...and password
    define('DB_HOST', '*******');     // ...and the server MySQL is running on
    
    // Change the prefix if you want to have multiple blogs in a single database.
    
    $table_prefix  = 'wp_';   // example: 'wp_' or 'b2' or 'mylogin_'
    
    // Turning off Post Revisions. Comment this line out if you would like them to be on.
    
    define('WP_POST_REVISIONS', false );
    
    // Change this to localize WordPress.  A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');
    
    define('WP_ALLOW_MULTISITE', true);
    
    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', false );
    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', 'www.mymythos.org' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );
    
    define( 'AUTH_KEY', 'i@(&gk9||49 TC!!7 ko=_Tr3u,EK@lvHekPW,,DN^R5)hmr;eM3R|ZwqX+;n)u6' );
    define( 'SECURE_AUTH_KEY', '~|saaYHr~{!z>}dTRjI9QUo=oH=D1Xnj|SdL8&O9BkT|*=WX@X?^Rd)).&s>p}=[' );
    define( 'LOGGED_IN_KEY', 's4gA{]=_PGMdm8~EyW7HeH7DUh7VXOWD1h9_|Ts}=~u$F6n&XVHhPq$<2bbF@7uQ' );
    define( 'NONCE_KEY', '=3;SH^9n~Jb2}xt=X.SotJ#-!j* KGfLI.-0W|oJKS,jgngT,[TsC.1CqF*X494s' );
    define( 'AUTH_SALT', '6(N@U@ao+eYz[!|Qg(t;Xj$?xv4|TJ&#

    an!yqN0I_%zrF w.t/hqcfP<+s[rh!-' );
    define( 'SECURE_AUTH_SALT', '<?bovaai(jx=Q<97=RPfpx>P2/[ZSW`u8-&iG;Jde]65tqe@RA2Z|^ =9.XIiU$s' );
    define( 'LOGGED_IN_SALT', 'I6edq3EHS4GGja-zM*Hnb=YZ&Q{hVgpa4{Xh5A]qM]Q@{fY|]e2=8L+mzxc_;u' );
    define( 'NONCE_SALT', 'e+^l)Jc4}/&uGU~I;c.Dt&-S&A@UfNoy[50+k^#5m/X(JAO%xe<^lQu4TxWI2{]n' );

    /* Stop editing */

    $server = DB_HOST;
    $loginsql = DB_USER;
    $passsql = DB_PASSWORD;
    $base = DB_NAME;

    define('ABSPATH', dirname(__FILE__).'/');

    // Get everything else
    require_once(ABSPATH.'wp-settings.php');
    ?>
    `

    * mod edit: obfuscated db username & password *

  24. SidianMSJones
    Member
    Posted 4 years ago #

    Sorry it jumped out of the code box somehow.

  25. SidianMSJones
    Member
    Posted 4 years ago #

    Sorry it jumped out of the code box somehow.

  26. SidianMSJones
    Member
    Posted 4 years ago #

    Here is a pic of the Sites area and the weird site names/URLS

    http://imgur.com/xJCUa.png

  27. SidianMSJones
    Member
    Posted 4 years ago #

    So I've been studying the wp-config a bit but still am not quite sure what would cause the strange URLs.

    Andrea do you see anything in there that would be the culprit?

  28. SidianMSJones
    Member
    Posted 4 years ago #

    Any help? Feels like were really close, and I know other people are having this issue as well.

  29. I can't see anything wrong in anything you've posted.

    Have you checked with your webhost? I do know Dreamhost (for example) will not support the network on their shared plans, and have quite possibly disabled it from working.

    Considering you fixed it and it came right back, my suspicion is host-related.

  30. SidianMSJones
    Member
    Posted 4 years ago #

    Talked to DreamHost (my host coincidentally) and they said it appears to be a software issue with WP. I do seem to remember WP stating something about how "there is already a version of 3.0 present" or something to that effect, perhaps that's doing it.

    In the meantime I think I'll have to just completely reinstall WP, hopefully without losing my posts, URLS, and theme customizations...ugh.

    Is there a better way here?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.