WordPress.org

Ready to get started?Download WordPress

Forums

Strange "Sidebar" problem (5 posts)

  1. djh-world
    Member
    Posted 9 years ago #

    Hi there.

    On my wordpress sidebar, underneath the "Archives" and "Links" sections, I have this horrible error underneath

    "WordPress database error: [Table 'blog.wp_posts' doesn't exist]
    SELECT DISTINCT YEAR(post_date) AS year, MONTH(post_date) AS month, count(ID) as posts FROM wp_posts WHERE post_date < '2005-07-14 19:50:00' AND post_status = 'publish' GROUP BY YEAR(post_date), MONTH(post_date) ORDER BY post_date DESC"

    Now this is wierd. because my WP database is called "wordpress" and I have a separate DB called "blog".

    My wp-config.php seems to have the correct settings, yet the sidebar seems to be looking elsewhere!

    This has only happened recently.

    Any ideas?

  2. jwurster
    Member
    Posted 9 years ago #

    What is your url?

  3. oriecat
    Member
    Posted 9 years ago #

    In your sidebar template, what comes underneath Archives and Links? What section is making the error?

  4. djh-world
    Member
    Posted 9 years ago #

    Hi there

    My blog is currently located on a local server so it's difficult to show you the problem fully.

    Here is a screenshot: -

    http://www.djh-solutions.co.uk/images/sidebar.png

    And you can download the php file here: -

    http://www.djh-solutions.co.uk/sidebar.php

  5. djh-world
    Member
    Posted 9 years ago #

    Pop, I've tried reintalling mysql, but to no avail.

    The problem persists.

Topic Closed

This topic has been closed to new replies.

About this Topic