WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Strange Post double address Mystery (9 posts)

  1. Spunky844
    Member
    Posted 3 years ago #

    Hello everyone,

    After moving a wordpress installation from a sub folder to the root all the posts have an extra long address redundancy:

    http://shenandoahweddings.org/http:/shenandoahweddings.org/category/brides

    How to fix?

    THanks a bunch!
    Andrew

  2. esmi
    Forum Moderator
    Posted 3 years ago #

  3. Spunky844
    Member
    Posted 3 years ago #

    Could you be a little more specific? Do I have the symlink problem or do I need to modify the login.php?

    Thanks a million,
    Andrew

  4. esmi
    Forum Moderator
    Posted 3 years ago #

    No - it's not a symlink problem nor do you need to modify the login.php.

  5. Spunky844
    Member
    Posted 3 years ago #

    Does it have to do with my .htaccess file from:

    10. If you are using Permalinks, go to the Administration > Settings > Permalinks panel and update your Permalink structure to your .htaccess file, which should be in the same directory as the main index.php file.

    My .htaccess file:
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

  6. esmi
    Forum Moderator
    Posted 3 years ago #

    No. what urls are entered in Settings -> General? Have you tried resetting your custom permalinks back to the default setting. If this works, then review Using_Permalinks before setting a custom permalink structure back up again.

  7. Spunky844
    Member
    Posted 3 years ago #

    Under settings general I have:
    Wordpress Address: http://shenandoahweddings.org
    Site Address: http://shenandoahweddings.org

    Under Permalinks I have the custom structure:
    /http:/shenandoahweddings.org/%postname%

    I saw there that I have /http:/ instead of /http://shenandoa... But when I try to change it it says the permalink is updated but removes the / leaving only /http:/shend...

  8. esmi
    Forum Moderator
    Posted 3 years ago #

    Now go and read Using_Permalinks again...

  9. Spunky844
    Member
    Posted 3 years ago #

    I changed the custom permalink to just /%postname% and that fixed it.

    Thank you for your help!!!
    Andrew

Topic Closed

This topic has been closed to new replies.

About this Topic