WordPress.org

Ready to get started?Download WordPress

Forums

Strange Numbers/Letters Appearing in Random Areas (17 posts)

  1. meshugakitty
    Member
    Posted 7 years ago #

    Hey there! This is kind of a question for those who use/have multiple browsers. I generally use Firefox, which is what I made the layout of my site under. Thus, my site should be best viewable under Firefox... and it was, but now something strange is going on and I haven't even messed with the presentation of my layout at all.

    If you have Firefox and would like to help, the link to my site is http://oklicious.isgreat.org. At the top where the Header is supposed to touch it instead lists the numbers/letters: 2F63 on the left and then 0 on the right side. Also, down every other post at the bottom, there are other random numbers/letters just above the categories/permalink list.

    I mention other browsers because I wanted to see what it looked like in them all to see if it was just a browser issue. So, I opened Opera and I viewed my site there and it looks perfect and how it should look in Firefox... how it used to look even. It appears the same in IE7 as it does in Firefox, minus the faulty positioning, but it wasn't made under IE7, so it wasn't meant to be viewed using it.

    I don't understand why the random numbers/letters at the header and the end of my posts are showing up.

    Can anyone help me out here?
    I'm using WP 2.0.5 if that helps with anything. Would it help if I upgraded to the latest 2.1?

  2. Doodlebee
    Member
    Posted 7 years ago #

    I'm looking in IE7 and Firefox both, and I don't see what you're talking about.

  3. meshugakitty
    Member
    Posted 7 years ago #

    Hm. That's strange. Maybe it's just something from my end. I don't know... I'll try to take a screen capture of it.

    Top:
    1.png

    At The End of Every Other Post:
    2.png

  4. sadish
    Member
    Posted 7 years ago #

    what are the plugins you have activated right now ? try disabling all of them and enable it one by one and refresh the site in between to find out the culprit.

  5. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    I don't see any of that either. It's also not in the page source. I suspect that you have an adblocker or some other kind of proxy interfering with your browsing.

  6. guyvan
    Member
    Posted 7 years ago #

    I'm seeing exactly the same thing with 2.1.2 and the tiga and WuCoco themes so far. Default doesn't seem to have it. Numbers appear in the source. Always 4 letters or numbers before the opening html and a 0 at the end it seems. No plugins activated. Fresh 2.1.2 install.

    21cb
    
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    	<head>

    I've got a site using exactly the same theme, I copied it over form there, on a different server and it doesn't have any problems on the original server but has these number on the new server? Numbers show up in IE6/7 and Firefox, not in Safari?

    Any ideas, this is driving me mad!

  7. guyvan
    Member
    Posted 7 years ago #

    From further testing it seems to be related to the height of the page. If I put anything in the sidebars or post too many posts so that the page scrolls a lot the numbers show up. Delete the posts or sidebar content and they go away!

  8. guyvan
    Member
    Posted 7 years ago #

    OK after a lot of debugging I'm no closer!

    <?php trackback_rdf(); ?>

    I'm trying to narrow it down to a specific call from the index, I thought it was the trackback as removing that seemed to fix the error but adding the comment sections back in gives me the error again.

  9. Performify
    Member
    Posted 7 years ago #

    I'm experiencing the exact same issue.

    We just moved http://ufcjunkie.com across servers.

    I'm getting the exact same behavior - random characters and numbers appearing throughout the site, only appears in firefox (v 2.0.0.2) but everything appears normal in IE.

  10. guyvan
    Member
    Posted 7 years ago #

    Not everyone see's the numbers. I can look at Performify's site from work and not see them but look from home and see them. Same with my sites.

    Work: Win xp with firefox 2.0.0.2 & IE6
    Home: OS X with firefox 2.0.0.2 & PC with IE 6/7

    To me this suggests that it's not browser related? Maybe it's proxy or filter related? Any ideas?

  11. guyvan
    Member
    Posted 7 years ago #

    OK an update! From home if I turn off my squid transparent proxy I do not get the errors anymore on any of the sites in either IE or firefox, turn it back on and problems appear again. So it's a proxy issue for sure.

    Not what I wanted to hear but at least it's a way forward. Would be interested to know if those having issues are using proxies (squid?) and if going around them solves the issue for them?

  12. Performify
    Member
    Posted 7 years ago #

    Wow, impressive troubleshooting work.

    I was indeed viewing the site through a proxy (squid) on the browser that was having trouble. When I turn off the proxy? No proxy, no problem.

    Not sure what this means - but my site renders just fine if I'm directly connected to the internet, and renders random letter/number characters otherwise.

    So you're right - its definitely squid.

    Other additional details:

    It doesn't seem to be template based or specific to a customization. We have a very vanilla install of WP 2.12 at http://live.ufcjunkie.com/ and it does the same thing - random characters through the proxy, no random characters after removing the proxy.

    I assumed this was an issue related to the server move, but I'm assuming instead its a bug with 2.12. Our old site was on the previous version and had no issues.

    Hopefully that helps someone in support track this issue down...

  13. Performify
    Member
    Posted 7 years ago #

    Guyvan,

    thanks to your great work identifying the specific issue, I was able to find this:

    http://trac.wordpress.org/ticket/3886

    Aplying the revisions suggested in that post fixed my issue. I have confirmed that the fix fixed the issue, on both of my wordpress sites which were having the issue.

    looks like the patch is going to be in 2.2, set for 04/23/07. If like me you can't wait that long, to fix manually yourself:

    edit functions.php under the wp-includes directory

    search for the following line in functions.php:

    nocache_headers

    immediately above that entry, you should see the following:

    if ( version_compare(phpversion(), '4.3.0', '>=') )
      @header("HTTP/1.1 $header $text", true, $header);
    else
      @header("HTTP/1.1 $header $text");

    what you need to do is comment out the two lines with @header in them (by placing // before it) and add the lines i've added below (each added line is commented below it with "above line added to fix squid"). The "if" and "else" statements stay the same...

    if ( version_compare(phpversion(), '4.3.0', '>=') )
        // @header("HTTP/1.1 $header $text", true, $header);
        // above line needs commented out
      @header($_SERVER["SERVER_PROTOCOL"]." $header $text", true, $header);
    //above line added to fix squid issue
    else
        // @header("HTTP/1.1 $header $text");
        // above line needs commented out
      @header($_SERVER["SERVER_PROTOCOL"]." $header $text");
    //above line added to fix squid

    Best of luck. Drop me an email or IM if you need help (contact info on my blog below), i owe you one for identifying that this was an issue particular to squid and thus letting me track it down...

    -Performify
    http://performify.com

  14. guyvan
    Member
    Posted 7 years ago #

    Worked for me too! Thanks for that, was driving me up the wall!!

  15. redecs
    Member
    Posted 7 years ago #

    the function is status_header(), not nocache_header();

    I was using Squid to, made the modifications and now it's ok!

    Thanks!

  16. sainait
    Member
    Posted 6 years ago #

    Thanks a lot.
    Our school uses SQUID. After made modification it runs OK. No problemo!
    thanks in advance

  17. bakuretsu
    Member
    Posted 6 years ago #

    Thanks to everyone here, especially guyvan and Performify for tracking down the Squid connection and the resulting fix!

    This was driving be absolutely crazy. I originally "solved" the problem by echoing a single space in the index.php file, but that probably only served to suppress all headers, which is definitely not a good long-term solution.

    Great work everyone!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags