WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
Strange irregularity with paths to my galleries (3 posts)

  1. ted_smith
    Member
    Posted 8 months ago #

    Hi

    Using WP 3.6.1 and NextGen-Gallery 3.4

    I have a series of Galleries in an album. All worked fine for a while but I recently a) migrated to a new server and b) updated NGG. I'm not sure at which stage my fault developed but the issue is this :

    a) All the galleries work fine via my main dropdown menu. You can see the menu in question at http://www.tedsmithphotography.com - see 'Portfolios', top left). The menu has working links to individual galleries as follows :

    http://www.tedsmithphotography.com/index.php/people/
    http://www.tedsmithphotography.com/index.php/landscapes/

    etc

    However, to account for users who click on the 'Portfolios' menu as opposed to the drop down sub-menu, I also have a page that lists all of my galleries as a group :

    http://www.tedsmithphotography.com/index.php/portfolios/

    In that page, I have a NGG shortcode to display the basic extended view:

    [ngg_images album_ids="1" display_type="photocrati-nextgen_basic_extended_album"]

    That displays the thumbnails (allbeit smaller than I want them to be but that's a less serious issue) and links to each of the galleries from the drop down menu. However, they all result in invalid pages. The links as represented in that page then become :

    http://www.tedsmithphotography.com/index.php/portfolios/nggallery/public-portfolio/people/

    http://www.tedsmithphotography.com/index.php/portfolios/nggallery/public-portfolio/landscapes/

    As you can see, they are different paths to galleries that are work fine via the menu.

    In the settings for each gallery, WP shows the absolute path as follows :

    wp-content/gallery/People
    wp-content/gallery/Landscapes

    I have never physically changed any of these paths and I don't understand why the links work via the menu but not via the overarching page?

    Can anyone help? (Yes, I tried updating permalinks, before anyone suggsts it)

    Thanks

    http://wordpress.org/plugins/nextgen-gallery/

  2. tizz
    Member
    Posted 8 months ago #

    Ted, I believe your issue is given by that index.php in the URL, that shouldn't be there. You said you migrated to a new server, and that's the stage ;)
    That server probably hasn't the rewrite mode on. So ask to your provider to set the rewrite on, necessary for permalinks.
    For thumbs size, you can define them individually from the ATP tabs in editor, or generally in Gallery settings, for extended album and galleries.

  3. ted_smith
    Member
    Posted 8 months ago #

    Hiya

    The index.php has always been there due to my site being in a sub-folder but not appearing to be by the normal URL.

    e.g. mysite.com/blog is where the WP files live, instead of in the root of mysite.com. It's a known WP technique to enable your web root to be kept a bit more organised, AFAIK.

    So all my URLs are prefixed with index.php as part of my custom permalinks structure.

    The rest of the site works fine, including the rest of NEXTGEN Gallery, apart from this one WP page tht lists my galleries.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.